RabbitMQ XSS attack via federation and shovel endpoints
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hosts and policy management information.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pivotal | RabbitMQ | 3.8 to before v3.8.1; 3.7 to before v3.7.20 | v3.8.1, v3.7.20 | Patch available | CNA |
| Pivotal | RabbitMQ for Pivotal Platform | 1.17 to before 1.17.4; 1.16 to before 1.16.7 | 1.17.4, 1.16.7 | Patch available | CNA |
| — | rabbit_common (Hex) | 3.7.0 to before 3.7.20 | 3.7.20 | Patch available | GHSA-9pf7-f47q-mwpq |
| — | rabbit_common (Hex) | 3.8.0 to before 3.8.1 | 3.8.1 | Patch available | GHSA-9pf7-f47q-mwpq |
- RabbitMQ VendorPivotal Affected 3.8 to before v3.8.1; 3.7 to before v3.7.20 Fixed in v3.8.1, v3.7.20 Patch available CNA
- RabbitMQ for Pivotal Platform VendorPivotal Affected 1.17 to before 1.17.4; 1.16 to before 1.16.7 Fixed in 1.17.4, 1.16.7 Patch available CNA
- rabbit_common (Hex) Vendor— Affected 3.7.0 to before 3.7.20 Fixed in 3.7.20 Patch available GHSA-9pf7-f47q-mwpq
- rabbit_common (Hex) Vendor— Affected 3.8.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-9pf7-f47q-mwpq
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* | 3.7.0 to before 3.7.20 | Vulnerable | Broadcom |
| cpe:2.3:a:broadcom:rabbitmq_server:3.8.0:*:*:*:*:*:*:* | 3.8.0 | Vulnerable | Broadcom |
| cpe:2.3:a:vmware:rabbitmq:*:*:*:*:*:pivotal_cloud_foundry:*:* | 1.16.0 to before 1.16.7; 1.17.0 to before 1.17.4 | Vulnerable | VMware |
| cpe:2.3:a:redhat:openstack:15:*:*:*:*:*:*:* | 15 | Vulnerable | Red Hat |
- cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* Versions 3.7.0 to before 3.7.20 Vulnerable ·Broadcom
- cpe:2.3:a:broadcom:rabbitmq_server:3.8.0:*:*:*:*:*:*:* Versions 3.8.0 Vulnerable ·Broadcom
- cpe:2.3:a:vmware:rabbitmq:*:*:*:*:*:pivotal_cloud_foundry:*:* Versions 1.16.0 to before 1.16.7; 1.17.0 to before 1.17.4 Vulnerable ·VMware
- cpe:2.3:a:redhat:openstack:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Red Hat
Remediation
- Fix · CNA RabbitMQ (Pivotal) Fixed in v3.8.1, v3.7.20
- Fix · CNA RabbitMQ for Pivotal Platform (Pivotal) Fixed in 1.17.4, 1.16.7
- Fix · GHSA-9pf7-f47q-mwpq rabbit_common (Hex) Fixed in 3.7.20 Advisory →
- Fix · GHSA-9pf7-f47q-mwpq rabbit_common (Hex) Fixed in 3.8.1 Advisory →
Red Hat 1 advisory
- RHSA-2020:0553 Released 2020-02-19 · Red Hat rating Lowrabbitmq-server security update
- Red Hat OpenStack Platform 15.0 rabbitmq-server-3.7.23-2.el8ost
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Pivotal RabbitMQ for Pivotal Platform 1.16.7, 1.17.4
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2019-08444 RabbitMQ Web Management Plugin DoS via heap overflowPriority MEDIUM 40
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16 (Train) | Affected | No fix yet |
| Red Hat OpenStack Platform 15.0 | Fixed | RHSA-2020:0553 |
Not affected: 4 products
- CloudForms Management Engine 5
- Red Hat Ansible Tower 3
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat OpenStack Platform 14 (Rocky)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11291
- 2026-10-03 Alias added: GHSA-9pf7-f47q-mwpq
References
More Pivotal vulnerabilities
- TI-2017-05637 Improper input validation in Pivotal Spring Data REST and Spring Boot CVSS 3.0CRITICAL 9.8
- TI-2016-04299 When processing authorization requests using the whitelabel views in Spring Security… CVSS 3.0HIGH 8.8
- TI-2018-01165 Code injection in Pivotal Spring Security OAuth CVSS 3.0CRITICAL 9.8
- TI-2018-11237 DoS Attack via Range Requests CVSS 3.1HIGH 7.5
- TI-2019-02791 Apps Manager unverified SSL certs in Cloud Controller proxy CVSS 3.0CRITICAL 9.8
- TI-2018-11239 On Demand Services SDK Timing Attack Vulnerability CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-11291 · CVE Program
- CVE-2019-11291 · NVD
- FIRST EPSS
- GHSA-9pf7-f47q-mwpq · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11291 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences