RabbitMQ Web Management Plugin DoS via heap overflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.
Summary
Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The "X-Reason" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pivotal | RabbitMQ for Pivotal Platform | 1.16 to before 1.16.7; 1.17 to before 1.17.4 | 1.16.7, 1.17.4 | Patch available | CNA |
| Pivotal | RabbitMQ | 3.7 to before v3.7.21; 3.8 to before v3.8.1 | v3.7.21, v3.8.1 | Patch available | CNA |
| — | RabbitMQ (Hex) | 3.7.0 to before 3.7.21 | 3.7.21 | Patch available | GHSA-hrfh-7j5f-8ccr |
| — | RabbitMQ (Hex) | 3.8.0 to before 3.8.1 | 3.8.1 | Patch available | GHSA-hrfh-7j5f-8ccr |
| — | RabbitMQ (Hex) | before 1.16.7 | 1.16.7 | Patch available | GHSA-hrfh-7j5f-8ccr |
| — | RabbitMQ (Hex) | 1.17.0 to before 1.17.4 | 1.17.4 | Patch available | GHSA-hrfh-7j5f-8ccr |
- RabbitMQ for Pivotal Platform VendorPivotal Affected 1.16 to before 1.16.7; 1.17 to before 1.17.4 Fixed in 1.16.7, 1.17.4 Patch available CNA
- RabbitMQ VendorPivotal Affected 3.7 to before v3.7.21; 3.8 to before v3.8.1 Fixed in v3.7.21, v3.8.1 Patch available CNA
- RabbitMQ (Hex) Vendor— Affected 3.7.0 to before 3.7.21 Fixed in 3.7.21 Patch available GHSA-hrfh-7j5f-8ccr
- RabbitMQ (Hex) Vendor— Affected 3.8.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-hrfh-7j5f-8ccr
- RabbitMQ (Hex) Vendor— Affected before 1.16.7 Fixed in 1.16.7 Patch available GHSA-hrfh-7j5f-8ccr
- RabbitMQ (Hex) Vendor— Affected 1.17.0 to before 1.17.4 Fixed in 1.17.4 Patch available GHSA-hrfh-7j5f-8ccr
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* | 3.8.0 to before 3.8.1 | Vulnerable | Broadcom |
| cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:pivotal_cloud_foundry:*:* | 1.16.0 to before 1.16.7; 1.17.0 to before 1.17.4 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:*:*:* | 3.7.0 to before 3.7.21 | Vulnerable | Spring by Pivotal |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
| cpe:2.3:a:redhat:openstack:15:*:*:*:*:*:*:* | 15 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* Versions 3.8.0 to before 3.8.1 Vulnerable ·Broadcom
- cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:pivotal_cloud_foundry:*:* Versions 1.16.0 to before 1.16.7; 1.17.0 to before 1.17.4 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:*:*:* Versions 3.7.0 to before 3.7.21 Vulnerable ·Spring by Pivotal
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
- cpe:2.3:a:redhat:openstack:15:*:*:*:*:*:*:* Versions 15 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA RabbitMQ for Pivotal Platform (Pivotal) Fixed in 1.16.7, 1.17.4
- Fix · CNA RabbitMQ (Pivotal) Fixed in v3.7.21, v3.8.1
- Fix · GHSA-hrfh-7j5f-8ccr RabbitMQ (Hex) Fixed in 3.7.21 Advisory →
- Fix · GHSA-hrfh-7j5f-8ccr RabbitMQ (Hex) Fixed in 3.8.1 Advisory →
- Fix · GHSA-hrfh-7j5f-8ccr RabbitMQ (Hex) Fixed in 1.16.7 Advisory →
- Fix · GHSA-hrfh-7j5f-8ccr RabbitMQ (Hex) Fixed in 1.17.4 Advisory →
Red Hat 1 advisory
- RHSA-2020:0078 Released 2020-01-13 · Red Hat rating Importantrabbitmq-server security update
- Red Hat OpenStack Platform 15.0 rabbitmq-server-3.7.22-1.el8ost
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Pivotal RabbitMQ for Pivotal Platform 1.16.7, 1.17.4
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2019-08448 RabbitMQ XSS attack via federation and shovel endpointsPriority LOW 23
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 14 (Rocky) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 16 (Train) | Affected | No fix yet |
| Red Hat OpenStack Platform 15.0 | Fixed | RHSA-2020:0078 |
Not affected: 3 products
- CloudForms Management Engine 5
- Red Hat Ansible Tower 3
- Red Hat OpenStack Platform 13 (Queens)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11287
- 2026-10-03 Alias added: GHSA-hrfh-7j5f-8ccr
References
Advisory 6
More Pivotal vulnerabilities
- TI-2017-05637 Improper input validation in Pivotal Spring Data REST and Spring Boot CVSS 3.0CRITICAL 9.8
- TI-2016-04299 When processing authorization requests using the whitelabel views in Spring Security… CVSS 3.0HIGH 8.8
- TI-2018-01165 Code injection in Pivotal Spring Security OAuth CVSS 3.0CRITICAL 9.8
- TI-2018-11237 DoS Attack via Range Requests CVSS 3.1HIGH 7.5
- TI-2019-02791 Apps Manager unverified SSL certs in Cloud Controller proxy CVSS 3.0CRITICAL 9.8
- TI-2018-11239 On Demand Services SDK Timing Attack Vulnerability CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-11287 · CVE Program
- CVE-2019-11287 · NVD
- FIRST EPSS
- GHSA-hrfh-7j5f-8ccr · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11287 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences