Integer overflow in bson_ensure_space
Priority LOW 34CWE-190Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
Kevin Backhouse discovered an integer overflow in bson_ensure_space, as used in whoopsie.
Why it matters now
EPSS 0.00443 38th percentileScored 2026-11-07
Fix Fixed whoopsie (Canonical): 0.2.52.5ubuntu0.2, 0.2.62ubuntu0.2, 0.2.66ubuntu0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | whoopsie | 0.2.52.5 to before 0.2.52.5ubuntu0.2; 0.2.62 to before 0.2.62ubuntu0.2; 0.2.66 to before 0.2.66ubuntu0.1 | 0.2.52.5ubuntu0.2, 0.2.62ubuntu0.2, 0.2.66ubuntu0.1 | Patch available | CNA |
- whoopsie VendorCanonical Affected 0.2.52.5 to before 0.2.52.5ubuntu0.2; 0.2.62 to before 0.2.62ubuntu0.2; 0.2.66 to before 0.2.66ubuntu0.1 Fixed in 0.2.52.5ubuntu0.2, 0.2.62ubuntu0.2, 0.2.66ubuntu0.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:whoopsie_project:whoopsie:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Whoopsie Project |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* | 19.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
- cpe:2.3:a:whoopsie_project:whoopsie:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Whoopsie Project
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* Versions 19.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
Remediation
- Fix · CNA whoopsie (Canonical) Fixed in 0.2.52.5ubuntu0.2, 0.2.62ubuntu0.2, 0.2.66ubuntu0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11484
- 2026-10-03 Alias added: GHSA-rwvc-6fhr-c2q7
References
More Canonical Ubuntu Linux vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-11484 · CVE Program
- CVE-2019-11484 · NVD
- FIRST EPSS
- GHSA-rwvc-6fhr-c2q7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences