Istio 1.1.x through 1.1.6 has Incorrect Access Control.
Priority LOW 35CWE-284Published · Updated
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Istio 1.1.x through 1.1.6 has Incorrect Access Control.
Why it matters now
EPSS 0.01175 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed istio.io/istio (Go): 1.1.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | istio.io/istio (Go) | 1.1.0 to before 1.1.7 | 1.1.7 | Patch available | GHSA-6g5f-f5pm-mjrg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- istio.io/istio (Go) Vendor— Affected 1.1.0 to before 1.1.7 Fixed in 1.1.7 Patch available GHSA-6g5f-f5pm-mjrg
Remediation
- Fix · GHSA-6g5f-f5pm-mjrg istio.io/istio (Go) Fixed in 1.1.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12243
- 2026-10-03 Alias added: GHSA-6g5f-f5pm-mjrg
References
More Istio vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2022-06055 Authorization Policy bypass in Istio CVSS 3.1CRITICAL 9.8
- TI-2021-11909 Istio before 1.8.6 and 1.9.x before 1.9.5 contains a remotely exploitable vulnerability… CVSS 3.1CRITICAL 9.8
- TI-2026-24390 Istio JWKS resolver to prevent private key material from being exposed when JWKS fetch fails. CVSS 4.0HIGH 8.7
- TI-2022-13090 Ill-formed headers may lead to unexpected behavior in Istio CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-12243 · CVE Program
- CVE-2019-12243 · NVD
- FIRST EPSS
- GHSA-6g5f-f5pm-mjrg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences