A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.
Priority MEDIUM 42CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A CSRF issue in phpMyAdmin 4.9.0.1 allows deletion of any server in the Setup page.
Why it matters now
EPSS 0.10666 95th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD and the CNA
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.9.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | before 4.9.1 | 4.9.1 | Patch available | GHSA-4c9q-64gq-xhx4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected before 4.9.1 Fixed in 4.9.1 Patch available GHSA-4c9q-64gq-xhx4
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* | up to 4.9.0.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* | 29 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
- cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions up to 4.9.0.1 Vulnerable ·phpMyAdmin
- cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* Versions 29 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-4c9q-64gq-xhx4 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.9.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12922
- 2026-10-03 Alias added: GHSA-4c9q-64gq-xhx4
References
Exploit 3
Patch 2
Advisory 6
Other 3
- https://lists.fedoraproject.org/archives/list/[email protected]/message/PBLBE6CSC2ZLINIRBUU5XBLXYVBTF3KA
- https://lists.fedoraproject.org/archives/list/[email protected]/message/QJ5BW2VEMD2P23ZYRWHDBEQHOKGKGWD6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YCB3PTGHZ7AJCM6BKCQRRP6HG3OKYCMN
Sources
- CVE-2019-12922 · CVE Program
- CVE-2019-12922 · NVD
- FIRST EPSS
- GHSA-4c9q-64gq-xhx4 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-12922 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences