The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command injection, which allows the remote attacker to achieve code execution, denial of service, or information disclosure by sending a crafted QMP command to the listening server. Note: This has been disputed as a non-issue since QEMU's -qmp interface is meant to be used by trusted users. If one is able to access this interface via a tcp socket open to the internet, then it is an insecure configuration issue
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Not affected: 9 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat OpenStack Platform 14 (Rocky)
- Red Hat OpenStack Platform 9 (Mitaka)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12928
- 2026-10-03 Alias added: GHSA-pwcf-p9qx-3948
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
- TI-2015-07039 Local privilege escalation vulnerability in the Gentoo QEMU package before 2.5.0-r1. CVSS 3.0CRITICAL 10.0
Sources
- CVE-2019-12928 · CVE Program
- CVE-2019-12928 · NVD
- FIRST EPSS
- GHSA-pwcf-p9qx-3948 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-12928 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences