Qemu: 9pfs: improper access control on special files
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
A flaw was found in the 9p passthrough filesystem (9pfs) implementation in QEMU. The 9pfs server did not prohibit opening special files on the host side, potentially allowing a malicious client to escape from the exported 9p tree by creating and opening a device file in the shared folder.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | qemu | — | 8.1.0-rc0 | Patch available | CNA |
- qemu Vendor— Affected — Fixed in 8.1.0-rc0 Patch available CNA
Remediation
- Fix · CNA qemu Fixed in 8.1.0-rc0
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 8 Advanced Virtualization
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2861
- 2026-10-03 Alias added: GHSA-6mxq-x623-25h9
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
- TI-2015-07039 Local privilege escalation vulnerability in the Gentoo QEMU package before 2.5.0-r1. CVSS 3.0CRITICAL 10.0
Sources
- CVE-2023-2861 · CVE Program
- CVE-2023-2861 · NVD
- FIRST EPSS
- GHSA-6mxq-x623-25h9 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-2861 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences