Incorrect default permissions in Red Hat samba
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
All Samba versions 4.x.x before 4.9.17, 4.10.x before 4.10.11 and 4.11.x before 4.11.3 have an issue, where the (poorly named) dnsserver RPC pipe provides administrative facilities to modify DNS records and zones. Samba, when acting as an AD DC, stores DNS records in LDAP. In AD, the default permissions on the DNS partition allow creation of new records by authenticated users. This is used for example to allow machines to self-register in DNS. If a DNS record was created that case-insensitively matched the name of the zone, the ldb_qsort() and dns_name_compare() routines could be confused into reading memory prior to the list of DNS entries when responding to DnssrvEnumRecords() or DnssrvEnumRecords2() and so following invalid memory as a pointer.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | samba | 4.11 to before 4.11.3; 4.10 to before 4.10.11; 4.x to before 4.9.17 | 4.11.3, 4.10.11, 4.9.17 | Patch available | CNA |
- samba VendorRed Hat Affected 4.11 to before 4.11.3; 4.10 to before 4.10.11; 4.x to before 4.9.17 Fixed in 4.11.3, 4.10.11, 4.9.17 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* | 4.0.0 to before 4.9.17; 4.10.0 to before 4.10.11; 4.11.0 to before 4.11.3 | Vulnerable | Samba |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* | 19.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.9.17; 4.10.0 to before 4.10.11; 4.11.0 to before 4.11.3 Vulnerable ·Samba
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* Versions 19.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA samba (Red Hat) Fixed in 4.11.3, 4.10.11, 4.9.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Red Hat samba — openSUSE-SU-2019:2700
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11074 Improper authorization in Red Hat sambaPriority LOW 29
- Advisory ·
Red Hat samba — FEDORA-2019-be98a08835
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11074 Improper authorization in Red Hat sambaPriority LOW 29
Show 3 more groups
- Advisory ·
Red Hat samba — FEDORA-2019-11dddb785b
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11074 Improper authorization in Red Hat sambaPriority LOW 29
- Advisory ·
Red Hat samba — USN-4217-1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11074 Improper authorization in Red Hat sambaPriority LOW 29
- Advisory ·
Red Hat samba — USN-4217-2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11074 Improper authorization in Red Hat sambaPriority LOW 29
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14861
- 2026-10-03 Alias added: GHSA-jhj7-p3xq-vh37
References
Advisory 11
- USN-4217-1
- USN-4217-2
- FEDORA-2019-be98a08835
- openSUSE-SU-2019:2700
- FEDORA-2019-11dddb785b
- GLSA-202003-52
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14861
- https://security.netapp.com/advisory/ntap-20191210-0002/
- https://www.samba.org/samba/security/CVE-2019-14861.html
- https://www.synology.com/security/advisory/Synology_SA_19_40
- [debian-lts-announce] 20210529 [SECURITY] [DLA 2668-1] samba security update
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-14861 · CVE Program
- CVE-2019-14861 · NVD
- FIRST EPSS
- GHSA-jhj7-p3xq-vh37 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14861 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences