Improper authorization in Red Hat samba
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-285.
Summary
All Samba versions 4.x.x before 4.9.17, 4.10.x before 4.10.11 and 4.11.x before 4.11.3 have an issue, where the S4U (MS-SFU) Kerberos delegation model includes a feature allowing for a subset of clients to be opted out of constrained delegation in any way, either S4U2Self or regular Kerberos authentication, by forcing all tickets for these clients to be non-forwardable. In AD this is implemented by a user attribute delegation_not_allowed (aka not-delegated), which translates to disallow-forwardable. However the Samba AD DC does not do that for S4U2Self and does set the forwardable flag even if the impersonated client has the not-delegated flag set.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | samba | 4.11 to before 4.11.3; 4.10 to before 4.10.11; 4.x to before 4.9.17 | 4.11.3, 4.10.11, 4.9.17 | Patch available | CNA |
- samba VendorRed Hat Affected 4.11 to before 4.11.3; 4.10 to before 4.10.11; 4.x to before 4.9.17 Fixed in 4.11.3, 4.10.11, 4.9.17 Patch available CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* | 4.0.0 to before 4.9.17; 4.10.0 to before 4.10.11; 4.11.0 to before 4.11.3 | Vulnerable | Samba |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* | 19.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.9.17; 4.10.0 to before 4.10.11; 4.11.0 to before 4.11.3 Vulnerable ·Samba
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* Versions 19.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA samba (Red Hat) Fixed in 4.11.3, 4.10.11, 4.9.17
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Red Hat samba — openSUSE-SU-2019:2700
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11065 Incorrect default permissions in Red Hat sambaPriority LOW 28
- Advisory ·
Red Hat samba — FEDORA-2019-be98a08835
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11065 Incorrect default permissions in Red Hat sambaPriority LOW 28
Show 3 more groups
- Advisory ·
Red Hat samba — FEDORA-2019-11dddb785b
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11065 Incorrect default permissions in Red Hat sambaPriority LOW 28
- Advisory ·
Red Hat samba — USN-4217-1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11065 Incorrect default permissions in Red Hat sambaPriority LOW 28
- Advisory ·
Red Hat samba — USN-4217-2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-11065 Incorrect default permissions in Red Hat sambaPriority LOW 28
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-14870
- 2026-10-03 Alias added: GHSA-6q5r-wx7g-rq28
References
Advisory 13
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14870
- USN-4217-1
- https://security.netapp.com/advisory/ntap-20191210-0002/
- https://www.samba.org/samba/security/CVE-2019-14870.html
- USN-4217-2
- FEDORA-2019-be98a08835
- https://www.synology.com/security/advisory/Synology_SA_19_40
- openSUSE-SU-2019:2700
- FEDORA-2019-11dddb785b
- GLSA-202003-52
- [debian-lts-announce] 20210529 [SECURITY] [DLA 2668-1] samba security update
- [debian-lts-announce] 20221126 [SECURITY] [DLA 3206-1] heimdal security update
- GLSA-202310-06
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-14870 · CVE Program
- CVE-2019-14870 · NVD
- FIRST EPSS
- GHSA-6q5r-wx7g-rq28 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-14870 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences