Jooby before 1.6.4 has XSS via the default error handler.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jooby before 1.6.4 has XSS via the default error handler.
Why it matters now
EPSS 0.00984 62nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.jooby:jooby (Maven): 1.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jooby:jooby (Maven) | before 1.6.4 | 1.6.4 | Patch available | GHSA-f5f4-m7qp-w6gc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jooby:jooby (Maven) Vendor— Affected before 1.6.4 Fixed in 1.6.4 Patch available GHSA-f5f4-m7qp-w6gc
Remediation
- Fix · GHSA-f5f4-m7qp-w6gc org.jooby:jooby (Maven) Fixed in 1.6.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15477
- 2026-10-03 Alias added: GHSA-f5f4-m7qp-w6gc
References
More Jooby vulnerabilities
- TI-2020-06143 HTTP response splitting in io.jooby:jooby-netty CVSS 3.1CRITICAL 9.8
- TI-2020-06168 Path traversal in io.jooby:jooby and org.jooby:jooby CVSS 3.1MEDIUM 5.3
Sources
- CVE-2019-15477 · CVE Program
- CVE-2019-15477 · NVD
- FIRST EPSS
- GHSA-f5f4-m7qp-w6gc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences