Apport reads PID files with elevated privileges
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-250.
Summary
Apport reads and writes information on a crashed process to /proc/pid with elevated privileges. Apport then determines which user the crashed process belongs to by reading /proc/pid through get_pid_info() in data/apport. An unprivileged user could exploit this to read information about a privileged running process by exploiting PID recycling. This information could then be used to obtain ASLR offsets for a process with an existing memory corruption vulnerability. The initial fix introduced regressions in the Python Apport library due to a missing argument in Report.add_proc_environ in apport/report.py. It also caused an autopkgtest failure when reading /proc/pid and with Python 2 compatibility by reading /proc maps. The initial and subsequent regression fixes are in 2.20.11-0ubuntu16, 2.20.11-0ubuntu8.6, 2.20.9-0ubuntu7.12, 2.20.1-0ubuntu2.22 and 2.14.1-0ubuntu3.29+esm3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | Apport | 2.14.1 to before 2.14.1-0ubuntu3.29+esm3; 2.20.1 to before 2.20.1-0ubuntu2.22; 2.20.9 to before 2.20.9-0ubuntu7.12; 2.20.11 to before 2.20.11-0ubuntu8.6 | 2.14.1-0ubuntu3.29+esm3, 2.20.1-0ubuntu2.22, 2.20.9-0ubuntu7.12, 2.20.11-0ubuntu8.6 | Patch available | CNA |
- Apport VendorCanonical Affected 2.14.1 to before 2.14.1-0ubuntu3.29+esm3; 2.20.1 to before 2.20.1-0ubuntu2.22; 2.20.9 to before 2.20.9-0ubuntu7.12; 2.20.11 to before 2.20.11-0ubuntu8.6 Fixed in 2.14.1-0ubuntu3.29+esm3, 2.20.1-0ubuntu2.22, 2.20.9-0ubuntu7.12, 2.20.11-0ubuntu8.6 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apport_project:apport:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Apport Project |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* | 19.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
- cpe:2.3:a:apport_project:apport:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Apport Project
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* Versions 19.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
Remediation
- Fix · CNA Apport (Canonical) Fixed in 2.14.1-0ubuntu3.29+esm3, 2.20.1-0ubuntu2.22, 2.20.9-0ubuntu7.12, 2.20.11-0ubuntu8.6
Timeline
- 2026-10-02 Threatist record created from CVE-2019-15790
- 2026-10-03 Alias added: GHSA-mv59-w8cf-g9q7
References
Exploit 3
Advisory 6
More Canonical Ubuntu Linux vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-15790 · CVE Program
- CVE-2019-15790 · NVD
- FIRST EPSS
- GHSA-mv59-w8cf-g9q7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences