LimeSurvey before v3.17.14 allows reflected XSS for escalating privileges from a…
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
LimeSurvey before v3.17.14 allows reflected XSS for escalating privileges from a low-privileged account to, for example, SuperAdmin. This occurs in application/core/Survey_Common_Action.php,
Why it matters now
EPSS 0.03674 89th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed limesurvey/limesurvey (Packagist): 3.17.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | limesurvey/limesurvey (Packagist) | before 3.17.14 | 3.17.14 | Patch available | GHSA-r5f2-4wf4-cv66 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- limesurvey/limesurvey (Packagist) Vendor— Affected before 3.17.14 Fixed in 3.17.14 Patch available GHSA-r5f2-4wf4-cv66
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* | before 3.17.4 | Vulnerable | LimeSurvey |
- cpe:2.3:a:limesurvey:limesurvey:*:*:*:*:*:*:*:* Versions before 3.17.4 Vulnerable ·LimeSurvey
Remediation
- Fix · GHSA-r5f2-4wf4-cv66 limesurvey/limesurvey (Packagist) Fixed in 3.17.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16173
- 2026-10-03 Alias added: GHSA-r5f2-4wf4-cv66
References
Exploit 3
More Limesurvey vulnerabilities
- TI-2020-09194 LimeSurvey before 4.1.12+200324 contains a path traversal vulnerability in… CVSS 3.1CRITICAL 9.8
- TI-2024-28662 An issue in the js_localize.php function of LimeSurvey v6.6.2 and before allows attackers… CVSS 3.1HIGH 8.8
- TI-2024-26167 Lime Survey <= 6.5.12 is vulnerable to Cross Site Request Forgery (CSRF). CVSS 3.1HIGH 8.8
- TI-2022-21122 LimeSurvey before v5.0.4 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1HIGH 7.2
- TI-2007-03523 Multiple PHP remote file inclusion vulnerabilities in LimeSurvey (aka PHPSurveyor)… CVSS 2.0MEDIUM 6.8
- TI-2018-12189 An issue was discovered in TCPDF before 6.2.22. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2019-16173 · CVE Program
- CVE-2019-16173 · NVD
- FIRST EPSS
- GHSA-r5f2-4wf4-cv66 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences