A missing permission check in Jenkins Support Core Plugin 2.63 and earlier allows…
Priority LOW 30CWE-281Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
A missing permission check in Jenkins Support Core Plugin 2.63 and earlier allows attackers with Overall/Read permission to delete support bundles.
Why it matters now
EPSS 0.00715 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:support-core (Maven): 2.64
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Support Core Plugin | up to 2.63 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:support-core (Maven) | before 2.64 | 2.64 | Patch available | GHSA-j52r-pmqv-wm38 |
- Jenkins Support Core Plugin VendorJenkins Affected up to 2.63 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:support-core (Maven) Vendor— Affected before 2.64 Fixed in 2.64 Patch available GHSA-j52r-pmqv-wm38
Remediation
- Fix · GHSA-j52r-pmqv-wm38 org.jenkins-ci.plugins:support-core (Maven) Fixed in 2.64 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-16539
- 2026-10-03 Alias added: GHSA-j52r-pmqv-wm38
References
Advisory 3
More Jenkins Support Core vulnerabilities
- TI-2019-12402 Path traversal in Jenkins Support Core Plugin CVSS 3.1MEDIUM 6.5
- TI-2022-08900 Jenkins Support Core Plugin 2.79 and earlier does not redact some sensitive information in the support bundle. CVSS 3.1MEDIUM 6.5
- TI-2022-22349 Incorrect authorization in Jenkins Support Core Plugin CVSS 3.1MEDIUM 6.5
- TI-2021-04701 Information disclosure in Jenkins Support Core Plugin CVSS 3.1MEDIUM 5.3
Sources
- CVE-2019-16539 · CVE Program
- CVE-2019-16539 · NVD
- FIRST EPSS
- GHSA-j52r-pmqv-wm38 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences