Jenkins Support Core Plugin 2.79 and earlier does not redact some sensitive information in the support bundle.
Priority LOW 31CWE-212Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-312.
Summary
Jenkins Support Core Plugin 2.79 and earlier does not redact some sensitive information in the support bundle.
Why it matters now
EPSS 0.00966 61st percentileScored 2026-11-07
Fix Fixed Jenkins Support Core Plugin (Jenkins project): 2.76.1, 2.72.2org.jenkins-ci.plugins:support-core (Maven): 2.79.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Support Core Plugin | up to 2.79 | 2.76.1, 2.72.2 | Patch available | CNA |
| — | org.jenkins-ci.plugins:support-core (Maven) | before 2.79.1 | 2.79.1 | Patch available | GHSA-5m8f-v3gw-h94w |
- Jenkins Support Core Plugin VendorJenkins Affected up to 2.79 Fixed in 2.76.1, 2.72.2 Patch available CNA
- org.jenkins-ci.plugins:support-core (Maven) Vendor— Affected before 2.79.1 Fixed in 2.79.1 Patch available GHSA-5m8f-v3gw-h94w
Remediation
- Fix · CNA Jenkins Support Core Plugin (Jenkins project) Fixed in 2.76.1, 2.72.2
- Fix · GHSA-5m8f-v3gw-h94w org.jenkins-ci.plugins:support-core (Maven) Fixed in 2.79.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25187
- 2026-10-03 Alias added: GHSA-5m8f-v3gw-h94w
References
More Jenkins Support Core vulnerabilities
- TI-2019-12402 Path traversal in Jenkins Support Core Plugin CVSS 3.1MEDIUM 6.5
- TI-2022-22349 Incorrect authorization in Jenkins Support Core Plugin CVSS 3.1MEDIUM 6.5
- TI-2019-12401 A missing permission check in Jenkins Support Core Plugin 2.63 and earlier allows… CVSS 3.1MEDIUM 6.5
- TI-2021-04701 Information disclosure in Jenkins Support Core Plugin CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-25187 · CVE Program
- CVE-2022-25187 · NVD
- FIRST EPSS
- GHSA-5m8f-v3gw-h94w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences