Read the docs
TI-2019-12410 Aliases CVE-2019-16548GHSA-x24m-wr2f-p3vc

Cross-site request forgery in Jenkins Google Compute Engine Plugin

Priority MEDIUM 40CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A cross-site request forgery vulnerability in Jenkins Google Compute Engine Plugin 4.1.1 and earlier in ComputeEngineCloud#doProvision could be used to provision new agents.

Why it matters now

EPSS 0.00859 58th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:google-compute-engine (Maven): 4.2.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Google Compute Engine Pluginup to 4.1.1—No fix listedCNA
—org.jenkins-ci.plugins:google-compute-engine (Maven)before 4.2.04.2.0Patch availableGHSA-x24m-wr2f-p3vc
  • Jenkins Google Compute Engine Plugin VendorJenkins Affected up to 4.1.1 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:google-compute-engine (Maven) Vendor— Affected before 4.2.0 Fixed in 4.2.0 Patch available GHSA-x24m-wr2f-p3vc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:google_compute_engine:*:*:*:*:*:jenkins:*:*before 4.2.0VulnerableJenkins
  • cpe:2.3:a:jenkins:google_compute_engine:*:*:*:*:*:jenkins:*:* Versions before 4.2.0 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-x24m-wr2f-p3vc org.jenkins-ci.plugins:google-compute-engine (Maven) Fixed in 4.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-16548
  2. 2026-10-03 Alias added: GHSA-x24m-wr2f-p3vc
  3. 2026-11-03 Priority changed: LOW → MEDIUM

References

  • TI-2023-27120 Cross-site request forgery in Jenkins NeuVector Vulnerability Scanner Plugin CVSS 3.1HIGH 8.8
  • TI-2019-12408 Authorization bypass in Jenkins Google Compute Engine Plugin CVSS 3.1MEDIUM 5.9
  • TI-2022-11618 Insufficiently protected credentials in Jenkins Google Compute Engine Plugin CVSS 3.1MEDIUM 4.3
  • TI-2019-12409 Missing authorization in Jenkins Google Compute Engine Plugin CVSS 3.1MEDIUM 4.3
  • TI-2023-27111 Missing authorization in Jenkins Google Compute Engine Plugin CVSS 3.1LOW 2.7

Sources