Cross-site request forgery in Jenkins NeuVector Vulnerability Scanner Plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery (CSRF) vulnerability in Jenkins NeuVector Vulnerability Scanner Plugin 1.22 and earlier allows attackers to connect to an attacker-specified hostname and port using attacker-specified username and password.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins NeuVector Vulnerability Scanner Plugin | up to 1.22 | — | No fix listed | CNA |
| — | io.jenkins.plugins:neuvector-vulnerability-scanner (Maven) | before 2.2 | 2.2 | Patch available | GHSA-wpfc-r5qq-7r7p |
- Jenkins NeuVector Vulnerability Scanner Plugin VendorJenkins Affected up to 1.22 Fixed in — No fix listed CNA
- io.jenkins.plugins:neuvector-vulnerability-scanner (Maven) Vendor— Affected before 2.2 Fixed in 2.2 Patch available GHSA-wpfc-r5qq-7r7p
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:neuvector_vulnerability_scanner:*:*:*:*:*:jenkins:*:* | before 2.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:jira:*:*:*:*:*:jenkins:*:* | before 3.1.2 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:google_compute_engine:*:*:*:*:*:jenkins:*:* | before 4.551.0 | Vulnerable | Jenkins |
| cpe:2.3:a:jenkins:matlab:*:*:*:*:*:jenkins:*:* | before 2.11.1 | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:neuvector_vulnerability_scanner:*:*:*:*:*:jenkins:*:* Versions before 2.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:jira:*:*:*:*:*:jenkins:*:* Versions before 3.1.2 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:google_compute_engine:*:*:*:*:*:jenkins:*:* Versions before 4.551.0 Vulnerable ·Jenkins
- cpe:2.3:a:jenkins:matlab:*:*:*:*:*:jenkins:*:* Versions before 2.11.1 Vulnerable ·Jenkins
Remediation
- Fix · GHSA-wpfc-r5qq-7r7p io.jenkins.plugins:neuvector-vulnerability-scanner (Maven) Fixed in 2.2 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins NeuVector Vulnerability Scanner Plugin — Jenkins Security Advisory 2023-11-29
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2023-27121 Missing authorization in Jenkins NeuVector Vulnerability Scanner PluginPriority LOW 21
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49673
- 2026-10-03 Alias added: GHSA-wpfc-r5qq-7r7p
References
More Jenkins Google Compute Engine vulnerabilities
- TI-2019-12410 Cross-site request forgery in Jenkins Google Compute Engine Plugin CVSS 3.1HIGH 8.8
- TI-2019-12408 Authorization bypass in Jenkins Google Compute Engine Plugin CVSS 3.1MEDIUM 5.9
- TI-2022-11618 Insufficiently protected credentials in Jenkins Google Compute Engine Plugin CVSS 3.1MEDIUM 4.3
- TI-2019-12409 Missing authorization in Jenkins Google Compute Engine Plugin CVSS 3.1MEDIUM 4.3
- TI-2023-27111 Missing authorization in Jenkins Google Compute Engine Plugin CVSS 3.1LOW 2.7
Sources
- CVE-2023-49673 · CVE Program
- CVE-2023-49673 · NVD
- FIRST EPSS
- GHSA-wpfc-r5qq-7r7p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences