SilverStripe through 4.4.x before 4.4.5 and 4.5.x before 4.5.2 allows Reflected XSS on…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-78.
Summary
SilverStripe through 4.4.x before 4.4.5 and 4.5.x before 4.5.2 allows Reflected XSS on the login form and custom forms. Silverstripe Forms allow malicious HTML or JavaScript to be inserted through non-scalar FormField attributes, which allows performing XSS (Cross-Site Scripting) on some forms built with user input (Request data). This can lead to phishing attempts to obtain a user's credentials or other sensitive user input.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/framework (Packagist) | 4.5.0 to before 4.5.2 | 4.5.2 | Patch available | GHSA-qvrv-2x7x-78x2 |
| — | silverstripe/framework (Packagist) | 4.0.0 to before 4.4.5 | 4.4.5 | Patch available | GHSA-qvrv-2x7x-78x2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/framework (Packagist) Vendor— Affected 4.5.0 to before 4.5.2 Fixed in 4.5.2 Patch available GHSA-qvrv-2x7x-78x2
- silverstripe/framework (Packagist) Vendor— Affected 4.0.0 to before 4.4.5 Fixed in 4.4.5 Patch available GHSA-qvrv-2x7x-78x2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* | 4.4.0 to before 4.4.5; 4.5.0 to before 4.5.2 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:silverstripe:*:*:*:*:*:*:*:* Versions 4.4.0 to before 4.4.5; 4.5.0 to before 4.5.2 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-qvrv-2x7x-78x2 silverstripe/framework (Packagist) Fixed in 4.5.2 Advisory →
- Fix · GHSA-qvrv-2x7x-78x2 silverstripe/framework (Packagist) Fixed in 4.4.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-19325
- 2026-10-03 Alias added: GHSA-qvrv-2x7x-78x2
References
Advisory 2
More Silverstripe vulnerabilities
- TI-2007-02239 Unspecified vulnerability in the search functionality in SilverStripe 2.0.0 has unknown impact and attack vectors. CVSS 2.0HIGH 10.0
- TI-2019-09110 In SilverStripe through 4.3.3, a missing warning about leaving install.php in a public… CVSS 3.1CRITICAL 9.8
- TI-2019-04049 All versions of SilverStripe 3 prior to 3.6.7 and 3.7.3, and all versions of SilverStripe… CVSS 3.0CRITICAL 9.8
- TI-2019-09281 In SilverStripe through 4.3.3, the previous fix for SS-2018-007 does not completely… CVSS 3.1HIGH 8.8
- TI-2011-04272 code/sitefeatures/PageCommentInterface.php in SilverStripe 2.4.x before 2.4.6 might allow… CVSS 2.0MEDIUM 6.8
- TI-2020-07421 In SilverStripe through 4.5, files uploaded via Forms to folders migrated from… CVSS 3.1HIGH 7.5
Sources
- CVE-2019-19325 · CVE Program
- CVE-2019-19325 · NVD
- FIRST EPSS
- GHSA-qvrv-2x7x-78x2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences