Improper privilege management in openshift/mariadb-apb
Priority LOW 30CWE-266Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-266.
Summary
An insecure modification vulnerability in the /etc/passwd file was found in the container openshift/mariadb-apb, affecting versions before the following 4.3.5, 4.2.21, 4.1.37, and 3.11.188-4 . An attacker with access to the container could use this flaw to modify /etc/passwd and escalate their privileges.
Why it matters now
EPSS 0.00258 17th percentileScored 2026-11-07
Fix Fixed Red Hat: 4 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Openshift Enterprise | openshift/mariadb-apb | Fixed in 4.3.5-202003020549; Fixed in 4.2.21-202002240343; Fixed in 4.1.37-202003021622; Fixed in 3.11.188-4 | — | No fix listed | CNA |
- openshift/mariadb-apb VendorOpenshift Enterprise Affected Fixed in 4.3.5-202003020549; Fixed in 4.2.21-202002240343; Fixed in 4.1.37-202003021622; Fixed in 3.11.188-4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openshift:*:*:*:*:*:*:*:* | before 3.11.188-4; 4.0.0 to before 4.1.37; 4.2.0 to before 4.2.21; 4.3.0 to before 4.3.5 | Vulnerable | Red Hat |
- cpe:2.3:a:redhat:openshift:*:*:*:*:*:*:*:* Versions before 3.11.188-4; 4.0.0 to before 4.1.37; 4.2.0 to before 4.2.21; 4.3.0 to before 4.3.5 Vulnerable ·Red Hat
Remediation
Red Hat 4 advisories
- RHSA-2020:0802 Released 2020-03-20 · Red Hat rating ModerateOpenShift Container Platform 3.11 openshift-enterprise-mariadb-apb security update
- Red Hat OpenShift Container Platform 3.11 openshift3/mariadb-apb
- RHSA-2020:0694 Released 2020-03-12 · Red Hat rating ModerateOpenShift Container Platform 4.1.38 security update
- Red Hat OpenShift Container Platform 4.1 openshift4/apb-base, openshift4/mariadb-apb, openshift4/mediawiki +4
- RHSA-2020:0681 Released 2020-03-10 · Red Hat rating ModerateOpenShift Container Platform 4.3.5 security update
- Red Hat OpenShift Container Platform 4.3 openshift4/apb-base, openshift4/mariadb-apb, openshift4/mysql-apb +2
Show 1 more Red Hat advisories
- RHSA-2020:0617 Released 2020-03-04 · Red Hat rating ModerateOpenShift Container Platform 4.2.21 security update
- Red Hat OpenShift Container Platform 4.2 openshift4/apb-base, openshift4/mariadb-apb, openshift4/mediawiki-apb +3
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2020:0802 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2020:0694 |
| Red Hat OpenShift Container Platform 4.2 | Fixed | RHSA-2020:0617 |
| Red Hat OpenShift Container Platform 4.3 | Fixed | RHSA-2020:0681 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-19346
- 2026-10-03 Alias added: GHSA-983g-8wfp-4rwm
References
More Red Hat Openshift vulnerabilities
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2015-06239 Red Hat JBoss A-MQ 6.x; BPM Suite (BPMS) 6.x; BRMS 6.x and 5.x; Data Grid (JDG) 6.x; Data… CVSS 3.0CRITICAL 9.8
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
- TI-2016-00709 Multiple unspecified API endpoints in Jenkins before 1.650 and LTS before 1.642.2 allow… CVSS 3.0HIGH 8.8
- TI-2024-11209 Rsync: info leak via uninitialized stack contents CVSS 3.1HIGH 7.5
Sources
- CVE-2019-19346 · CVE Program
- CVE-2019-19346 · NVD
- FIRST EPSS
- GHSA-983g-8wfp-4rwm · GitHub Advisory Database · CC BY 4.0
- CVE-2019-19346 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences