Read the docs
TI-2019-13980 Aliases CVE-2019-19376GHSA-rc37-w42j-7p74

In Octopus Deploy before 2019.10.6, an authenticated user with TeamEdit permission could…

Priority LOW 31CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.

Summary

In Octopus Deploy before 2019.10.6, an authenticated user with TeamEdit permission could send a malformed Team API request that bypasses input validation and causes an application level denial of service condition. (The fix for this was also backported to LTS 2019.9.8 and LTS 2019.6.14.)

Why it matters now

EPSS 0.00988 62nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:-:*:*:*before 2019.10.7VulnerableOctopus Deploy
cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:lts:*:*:*2019.6.0 to before 2019.6.14; 2019.9.0 to before 2019.9.8VulnerableOctopus Deploy
  • cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:-:*:*:* Versions before 2019.10.7 Vulnerable ·Octopus Deploy
  • cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:lts:*:*:* Versions 2019.6.0 to before 2019.6.14; 2019.9.0 to before 2019.9.8 Vulnerable ·Octopus Deploy

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-19376
  2. 2026-10-03 Alias added: GHSA-rc37-w42j-7p74

References

  • TI-2020-08583 In Octopus Deploy before 2020.1.5, for customers running on-premises Active Directory… CVSS 3.1HIGH 8.8
  • TI-2018-04116 An issue was discovered in Octopus Deploy before 4.1.9. CVSS 3.0HIGH 8.8
  • TI-2018-03438 In Octopus Deploy versions 3.2.11 - 4.1.5 (fixed in 4.1.6), an authenticated user with… CVSS 3.0HIGH 8.8
  • TI-2017-12930 In Octopus Deploy before 4.1.3, the machine update process doesn't check that the user… CVSS 3.0HIGH 8.8
  • TI-2019-08703 In Octopus Deploy 2019.1.0 through 2019.3.1 and 2019.4.0 through 2019.4.5, an… CVSS 3.0HIGH 8.1
  • TI-2020-15818 In Octopus Deploy 3.1.0 to 2020.4.0, certain scripts can reveal sensitive information to the user in the task logs. CVSS 3.1HIGH 7.5
See all 30 →

Sources