WP HTML Mail < 2.9.1 - HTML Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WP HTML Mail plugin for WordPress is vulnerable to HTML injection in versions up to, and including, 2.9.0.3 due to insufficient input sanitization. This makes it possible for unauthenticated attackers to inject arbitrary HTML in pages that execute if they can successfully trick a administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| haet | Email Template Designer – WP HTML Mail | before 2.9.1 | 2.9.1 | Patch available | CNA |
- Email Template Designer – WP HTML Mail Vendorhaet Affected before 2.9.1 Fixed in 2.9.1 Patch available CNA
Remediation
- Fix · CNA Email Template Designer – WP HTML Mail (haet) Fixed in 2.9.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-25148
- 2026-10-03 Alias added: GHSA-x8mh-qq9c-qg4c
References
More codemiq Wp Html Mail vulnerabilities
- TI-2023-21072 WordPress WP HTML Mail Plugin <= 3.4.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2019-15247 WP HTML Mail < 2.2.11 - HTML injection CVSS 3.1MEDIUM 6.1
Sources
- CVE-2019-25148 · CVE Program
- CVE-2019-25148 · NVD
- FIRST EPSS
- GHSA-x8mh-qq9c-qg4c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences