Read the docs

Improper authorization in Jenkins

Priority LOW 35CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 8 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-285.

Summary

An improper authorization vulnerability exists in Jenkins 2.158 and earlier, LTS 2.150.1 and earlier in core/src/main/java/hudson/security/TokenBasedRememberMeServices2.java that allows attackers with Overall/RunScripts permission to craft Remember Me cookies that would never expire, allowing e.g. to persist access to temporarily compromised user accounts.

Why it matters now

EPSS 0.01545 75th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.150.2, 2.159Red Hat: 1 fixed, 8 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins2.158 and earlier, LTS 2.150.1 and earlier—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.150.22.150.2Patch availableGHSA-6rh5-23hx-j452
—org.jenkins-ci.main:jenkins-core (Maven)2.151 to before 2.1592.159Patch availableGHSA-6rh5-23hx-j452
  • Jenkins VendorJenkins Affected 2.158 and earlier, LTS 2.150.1 and earlier Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.150.2 Fixed in 2.150.2 Patch available GHSA-6rh5-23hx-j452
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.151 to before 2.159 Fixed in 2.159 Patch available GHSA-6rh5-23hx-j452

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.150.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.158VulnerableJenkins
cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*3.11VulnerableRed Hat
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.150.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.158 Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-6rh5-23hx-j452 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.150.2 Advisory →
  • Fix · GHSA-6rh5-23hx-j452 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.159 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.2AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.3AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.4AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.5AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.6AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.7AffectedNo fix planned: Out of support scope
Red Hat OpenShift Container Platform 3.9AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 3.11Fixed—
Not affected: 1 product
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1003003
  2. 2026-10-03 Alias added: GHSA-6rh5-23hx-j452

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources