Information disclosure in Jenkins OpenId Connect Authentication Plugin
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
An exposure of sensitive information vulnerability exists in Jenkins OpenId Connect Authentication Plugin 1.4 and earlier in OicSecurityRealm/config.jelly that allows attackers able to view a Jenkins administrator's web browser output, or control the browser (e.g. malicious extension) to retrieve the configured client secret.
Why it matters now
EPSS 0.01131 66th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:oic-auth (Maven): 1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins OpenId Connect Authentication Plugin | up to 1.4 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:oic-auth (Maven) | before 1.5 | 1.5 | Patch available | GHSA-3858-58w9-wpcg |
- Jenkins OpenId Connect Authentication Plugin VendorJenkins Affected up to 1.4 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:oic-auth (Maven) Vendor— Affected before 1.5 Fixed in 1.5 Patch available GHSA-3858-58w9-wpcg
Remediation
- Fix · GHSA-3858-58w9-wpcg org.jenkins-ci.plugins:oic-auth (Maven) Fixed in 1.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1003021
- 2026-10-03 Alias added: GHSA-3858-58w9-wpcg
References
More Jenkins Openid Connect Authentication vulnerabilities
- TI-2023-10046 Jenkins OpenId Connect Authentication Plugin 2.4 and earlier does not invalidate the previous session on login. CVSS 3.1HIGH 8.8
- TI-2025-18136 Incorrect default permissions in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.8
- TI-2024-35220 Insufficient session expiration in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.8
- TI-2024-32075 Improper authentication in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.1
- TI-2024-32074 Improper authentication in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.1
- TI-2023-27701 Open redirect in Jenkins OpenId Connect Authentication Plugin CVSS 3.1MEDIUM 6.1
Sources
- CVE-2019-1003021 · CVE Program
- CVE-2019-1003021 · NVD
- FIRST EPSS
- GHSA-3858-58w9-wpcg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences