Insufficient session expiration in Jenkins OpenId Connect Authentication Plugin
Priority MEDIUM 41CWE-613Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass, Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-613 and CWE-384.
Summary
Jenkins OpenId Connect Authentication Plugin 4.418.vccc7061f5b_6d and earlier does not invalidate the previous session on login.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00663 51st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:oic-auth (Maven): 4.421.v5422614eb
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins OpenId Connect Authentication Plugin | up to 4.418.vccc7061f5b_6d | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:oic-auth (Maven) | before 4.421.v5422614eb | 4.421.v5422614eb | Patch available | GHSA-h23j-73ww-7594 |
- Jenkins OpenId Connect Authentication Plugin VendorJenkins Affected up to 4.418.vccc7061f5b_6d Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:oic-auth (Maven) Vendor— Affected before 4.421.v5422614eb Fixed in 4.421.v5422614eb Patch available GHSA-h23j-73ww-7594
Remediation
- Fix · GHSA-h23j-73ww-7594 org.jenkins-ci.plugins:oic-auth (Maven) Fixed in 4.421.v5422614eb Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52553
- 2026-10-03 Alias added: GHSA-h23j-73ww-7594
- 2026-10-23 EPSS moved to the 50th–90th percentile
References
More Jenkins Openid Connect Authentication vulnerabilities
- TI-2023-10046 Jenkins OpenId Connect Authentication Plugin 2.4 and earlier does not invalidate the previous session on login. CVSS 3.1HIGH 8.8
- TI-2025-18136 Incorrect default permissions in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.8
- TI-2024-32075 Improper authentication in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.1
- TI-2024-32074 Improper authentication in Jenkins OpenId Connect Authentication Plugin CVSS 3.1HIGH 8.1
- TI-2023-27701 Open redirect in Jenkins OpenId Connect Authentication Plugin CVSS 3.1MEDIUM 6.1
- TI-2019-15866 Information disclosure in Jenkins OpenId Connect Authentication Plugin CVSS 3.0MEDIUM 4.3
Sources
- CVE-2024-52553 · CVE Program
- CVE-2024-52553 · NVD
- FIRST EPSS
- GHSA-h23j-73ww-7594 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences