Cross-site scripting in Zammad
Priority LOW 30CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-80.
Summary
Zammad GmbH Zammad 2.3.0 and earlier is affected by: Cross Site Scripting (XSS) - CWE-80. The impact is: Execute java script code on users browser. The component is: web app. The attack vector is: the victim must open a ticket. The fixed version is: 2.3.1, 2.2.2 and 2.1.3.
Why it matters now
EPSS 0.01257 69th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zammad GmbH | Zammad | ≤ 2.3.0 [fixed: 2.3.1; 2.2.2 and 2.1.3] | — | No fix listed | CNA |
- Zammad VendorZammad GmbH Affected ≤ 2.3.0 [fixed: 2.3.1; 2.2.2 and 2.1.3] Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* | 2.1.0 – 2.1.2; 2.2.0 – 2.2.1 | Vulnerable | Zammad GmbH |
| cpe:2.3:a:zammad:zammad:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Zammad GmbH |
- cpe:2.3:a:zammad:zammad:*:*:*:*:*:*:*:* Versions 2.1.0 – 2.1.2; 2.2.0 – 2.2.1 Vulnerable ·Zammad GmbH
- cpe:2.3:a:zammad:zammad:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Zammad GmbH
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1010018
- 2026-10-03 Alias added: GHSA-qhqc-h6cg-hx9p
References
More Zammad GmbH Zammad vulnerabilities
- TI-2026-65406 Local privilege escalation in Zammad v1.5.0 to v7.2.2 installed via DEB or RPM package KEVCVSS 4.0CRITICAL 9.4
- TI-2026-65405 Undisclosed RCE in Zammad v6.3 and higher KEVCVSS 4.0CRITICAL 9.4
- TI-2024-22252 An issue was discovered in Zammad before 6.3.0. CVSS 3.1CRITICAL 9.1
- TI-2022-23785 A vulnerability in Zammad v5.3.0 allows attackers to execute arbitrary code or escalate… CVSS 3.1CRITICAL 9.8
- TI-2021-18599 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
- TI-2021-18603 An issue was discovered in Zammad before 4.1.1. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-1010018 · CVE Program
- CVE-2019-1010018 · NVD
- FIRST EPSS
- GHSA-qhqc-h6cg-hx9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences