Apache SpamAssassin has an OS Command Injection vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-78.
Summary
In Apache SpamAssassin before 3.4.5, malicious rule configuration (.cf) files can be configured to run system commands without any output or errors. With this, exploits can be injected in a number of scenarios. In addition to upgrading to SA version 3.4.5, users should only use update channels or 3rd party .cf files from trusted places.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache SpamAssassin | Apache SpamAssassin to before 3.4.5 | 3.4.5 | Patch available | CNA |
- Apache SpamAssassin VendorApache Affected Apache SpamAssassin to before 3.4.5 Fixed in 3.4.5 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:spamassassin:*:*:*:*:*:*:*:* | before 3.4.5 | Vulnerable | Apache |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
- cpe:2.3:a:apache:spamassassin:*:*:*:*:*:*:*:* Versions before 3.4.5 Vulnerable ·Apache
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Apache SpamAssassin (Apache Software Foundation) Fixed in 3.4.5
Red Hat 1 advisory
- RHSA-2021:4315 Released 2021-11-09 · Red Hat rating Moderatespamassassin security update
- Red Hat Enterprise Linux AppStream (v. 8) spamassassin-3.4.4-4.el8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2021:4315 |
Not affected: 1 product
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2020-1946
- 2026-10-03 Alias added: GHSA-qmmx-pr2m-q429
References
More Apache Spamassassin vulnerabilities
- TI-2006-02383 SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch… CVSS 2.0MEDIUM 5.1
- TI-2018-08437 A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2. CVSS 3.0CRITICAL 9.8
- TI-2020-01855 OS command injection in Apache SpamAssassin CVSS 3.1HIGH 8.1
- TI-2020-01854 OS command injection in Apache SpamAssassin CVSS 3.1HIGH 8.1
- TI-2019-09265 Uncontrolled resource consumption in Apache SpamAssassin CVSS 3.1HIGH 7.5
- TI-2018-08438 Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax. CVSS 3.0HIGH 7.8
Sources
- CVE-2020-1946 · CVE Program
- CVE-2020-1946 · NVD
- FIRST EPSS
- GHSA-qmmx-pr2m-q429 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-1946 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences