A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache SpamAssassin | before 3.4.2 | 3.4.2 | Patch available | CNA |
- Apache SpamAssassin VendorApache Affected before 3.4.2 Fixed in 3.4.2 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:spamassassin:*:*:*:*:*:*:*:* | before 3.4.2 | Vulnerable | Apache |
| cpe:2.3:a:pdfinfo_project:pdfinfo:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Pdfinfo Project |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:apache:spamassassin:*:*:*:*:*:*:*:* Versions before 3.4.2 Vulnerable ·Apache
- cpe:2.3:a:pdfinfo_project:pdfinfo:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Pdfinfo Project
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · CNA Apache SpamAssassin (Apache Software Foundation) Fixed in 3.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Apache SpamAssassin — USN-3811-1
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2018-08438 Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.Priority LOW 36
- TI-2017-11478 Improper input validation in Apache SpamAssassinPriority LOW 35
- Advisory ·
Apache SpamAssassin — USN-3811-3
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2018-08438 Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.Priority LOW 36
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11780
- 2026-10-03 Alias added: GHSA-ph2p-v983-f856
References
More Apache Spamassassin vulnerabilities
- TI-2006-02383 SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch… CVSS 2.0MEDIUM 5.1
- TI-2020-01870 Apache SpamAssassin has an OS Command Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2020-01855 OS command injection in Apache SpamAssassin CVSS 3.1HIGH 8.1
- TI-2020-01854 OS command injection in Apache SpamAssassin CVSS 3.1HIGH 8.1
- TI-2019-09265 Uncontrolled resource consumption in Apache SpamAssassin CVSS 3.1HIGH 7.5
- TI-2018-08438 Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax. CVSS 3.0HIGH 7.8
Sources
- CVE-2018-11780 · CVE Program
- CVE-2018-11780 · NVD
- FIRST EPSS
- GHSA-ph2p-v983-f856 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11780 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences