Read the docs
TI-2020-01882 Aliases CVE-2020-1958GHSA-qh2g-7h5p-mxf4

Injection in Apache Druid

Priority LOW 36CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

When LDAP authentication is enabled in Apache Druid 0.17.0, callers of Druid APIs with a valid set of LDAP credentials can bypass the credentialsValidator.userSearch filter barrier that determines if a valid LDAP user is allowed to authenticate with Druid. They are still subject to role-based authorization checks, if configured. Callers of Druid APIs can also retrieve any LDAP attribute values of users that exist on the LDAP server, so long as that information is visible to the Druid server. This information disclosure does not require the caller itself to be a valid LDAP user.

Why it matters now

EPSS 0.04565 91st percentileScored 2026-11-07
Fix Fixed org.apache.druid:druid (Maven): 0.17.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Druid0.17.0—No fix listedCNA
—org.apache.druid:druid (Maven)0.17.0 to before 0.17.10.17.1Patch availableGHSA-qh2g-7h5p-mxf4
  • Apache Druid VendorApache Affected 0.17.0 Fixed in — No fix listed CNA
  • org.apache.druid:druid (Maven) Vendor— Affected 0.17.0 to before 0.17.1 Fixed in 0.17.1 Patch available GHSA-qh2g-7h5p-mxf4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:druid:0.17.0:*:*:*:*:*:*:*0.17.0VulnerableApache
  • cpe:2.3:a:apache:druid:0.17.0:*:*:*:*:*:*:* Versions 0.17.0 Vulnerable ·Apache

Remediation

  • Fix · GHSA-qh2g-7h5p-mxf4 org.apache.druid:druid (Maven) Fixed in 0.17.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-1958
  2. 2026-10-03 Alias added: GHSA-qh2g-7h5p-mxf4

References

Other 16

  • TI-2021-07779 Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. CVSS 3.1HIGH 8.8
  • TI-2021-14874 Incorrect authorization in Apache Druid CVSS 3.1MEDIUM 6.5
  • TI-2021-08525 Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. CVSS 3.1HIGH 8.8
  • TI-2026-19261 Apache Druid: Authentication Bypass via LDAP Anonymous Bind CVSS 3.1CRITICAL 9.8
  • TI-2025-36949 Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly. CVSS 3.1CRITICAL 9.8
  • TI-2021-08526 Apache Druid: The HTTP inputSource allows authenticated users to read data from other sources than intended CVSS 3.1MEDIUM 6.5
See all 11 →

Sources