Read the docs
TI-2026-19261 Aliases CVE-2026-23906GHSA-q672-hfc7-g833

Apache Druid: Authentication Bypass via LDAP Anonymous Bind

Priority MEDIUM 51CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Affected Products and Versions * Apache Druid * Affected Versions: 0.17.0 through 35.x (all versions prior to 36.0.0) * Prerequisites: * druid-basic-security extension enabled * LDAP authenticator configured * Underlying LDAP server permits anonymous bind                                                                                                                                                    Vulnerability Description An authentication bypass vulnerability exists in Apache Druid when using the druid-basic-security extension with LDAP authentication. If the underlying LDAP server is configured to allow anonymous binds, an attacker can bypass authentication by providing an existing username with an empty password. This allows unauthorized access to otherwise restricted Druid resources without valid credentials. The vulnerability stems from improper validation of LDAP authentication responses when anonymous binds are permitted, effectively treating anonymous bind success as valid user authentication. Impact A remote, unauthenticated attacker can: * Gain unauthorized access to the Apache Druid cluster * Access sensitive data stored in Druid datasources * Execute queries and potentially manipulate data * Access administrative interfaces if the bypassed account has elevated privileges * Completely compromise the confidentiality, integrity, and availability of the Druid deployment                                                                                                                                                                                     Mitigation   Immediate Mitigation (No Druid Upgrade Required):                                                                                                                                                   * Disable anonymous bind on your LDAP server. This prevents the vulnerability from being exploitable and is the recommended immediate action. Resolution * Upgrade Apache Druid to version 36.0.0 or later, which includes fixes to properly reject anonymous LDAP bind attempts.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01066 64th percentileScored 2026-11-07
Fix Fixed Apache Druid (Apache Software Foundation): 36.0.0org.apache.druid.extensions:druid-basic-security (Maven): 36.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Druid0.17.0 to before 36.0.036.0.0Patch availableCNA
—org.apache.druid.extensions:druid-basic-security (Maven)0.17.0 to before 36.0.036.0.0Patch availableGHSA-q672-hfc7-g833
  • Apache Druid VendorApache Affected 0.17.0 to before 36.0.0 Fixed in 36.0.0 Patch available CNA
  • org.apache.druid.extensions:druid-basic-security (Maven) Vendor— Affected 0.17.0 to before 36.0.0 Fixed in 36.0.0 Patch available GHSA-q672-hfc7-g833

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:druid:*:*:*:*:*:*:*:*0.17.0 to before 36.0.0VulnerableApache
  • cpe:2.3:a:apache:druid:*:*:*:*:*:*:*:* Versions 0.17.0 to before 36.0.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Druid (Apache Software Foundation) Fixed in 36.0.0
  • Fix · GHSA-q672-hfc7-g833 org.apache.druid.extensions:druid-basic-security (Maven) Fixed in 36.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-23906
  2. 2026-10-03 Alias added: GHSA-q672-hfc7-g833

References

  • TI-2021-07779 Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. CVSS 3.1HIGH 8.8
  • TI-2021-14874 Incorrect authorization in Apache Druid CVSS 3.1MEDIUM 6.5
  • TI-2021-08525 Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. CVSS 3.1HIGH 8.8
  • TI-2025-36949 Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly. CVSS 3.1CRITICAL 9.8
  • TI-2021-08526 Apache Druid: The HTTP inputSource allows authenticated users to read data from other sources than intended CVSS 3.1MEDIUM 6.5
  • TI-2020-01882 Injection in Apache Druid CVSS 3.1MEDIUM 6.5
See all 11 →

Sources