Incorrect authorization in Jenkins
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
Jenkins 2.218 and earlier, LTS 2.204.1 and earlier allowed users with Overall/Read access to view a JVM memory usage chart.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | up to 2.218; up to LTS 2.204.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.204.2 | 2.204.2 | Patch available | GHSA-r78q-qgx6-64pp |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.205 to before 2.219 | 2.219 | Patch available | GHSA-r78q-qgx6-64pp |
- Jenkins VendorJenkins Affected up to 2.218; up to LTS 2.204.1 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.204.2 Fixed in 2.204.2 Patch available GHSA-r78q-qgx6-64pp
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.205 to before 2.219 Fixed in 2.219 Patch available GHSA-r78q-qgx6-64pp
Remediation
- Fix · GHSA-r78q-qgx6-64pp org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.204.2 Advisory →
- Fix · GHSA-r78q-qgx6-64pp org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.219 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins — RHBA-2020:0402
7 records Highest priority Priority LOW 7 LOW
Other records, highest priority first
- TI-2020-01976 Jenkins 2.213 and earlier, LTS 2.204.1 and earlier improperly reuses encryption key…Priority LOW 39
- TI-2020-01980 Information disclosure in JenkinsPriority LOW 34
- TI-2020-01977 Jenkins 2.218 and earlier, LTS 2.204.1 and earlier was vulnerable to a UDP amplification…Priority LOW 32
- Advisory ·
Jenkins — RHBA-2020:0675
7 records Highest priority Priority LOW 7 LOW
Other records, highest priority first
- TI-2020-01976 Jenkins 2.213 and earlier, LTS 2.204.1 and earlier improperly reuses encryption key…Priority LOW 39
- TI-2020-01980 Information disclosure in JenkinsPriority LOW 34
- TI-2020-01977 Jenkins 2.218 and earlier, LTS 2.204.1 and earlier was vulnerable to a UDP amplification…Priority LOW 32
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Fixed | — |
| Red Hat OpenShift Container Platform 4.3 | Fixed | — |
| Red Hat OpenShift Container Platform 4.4 | Fixed | — |
| Red Hat OpenShift Container Platform 4.5 | Fixed | — |
Not affected: 1 product
- Red Hat OpenShift Container Platform 4.3
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2104
- 2026-10-03 Alias added: GHSA-r78q-qgx6-64pp
- 2026-10-31 Fix available: Red Hat OpenShift Container Platform 4.4, Red Hat OpenShift Container Platform 4.5 · Red Hat
References
Advisory 7
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2020-2104 · CVE Program
- CVE-2020-2104 · NVD
- FIRST EPSS
- GHSA-r78q-qgx6-64pp · GitHub Advisory Database · CC BY 4.0
- CVE-2020-2104 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences