Cross-site scripting in Jenkins Code Coverage API Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Code Coverage API Plugin 1.1.2 and earlier does not escape the filename of the coverage report used in its view, resulting in a stored XSS vulnerability exploitable by users able to change job configurations.
Why it matters now
EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:code-coverage-api (Maven): 1.1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Code Coverage API Plugin | up to 1.1.2 | — | No fix listed | CNA |
| — | io.jenkins.plugins:code-coverage-api (Maven) | before 1.1.3 | 1.1.3 | Patch available | GHSA-xg77-xqhq-crpr |
- Jenkins Code Coverage API Plugin VendorJenkins Affected up to 1.1.2 Fixed in — No fix listed CNA
- io.jenkins.plugins:code-coverage-api (Maven) Vendor— Affected before 1.1.3 Fixed in 1.1.3 Patch available GHSA-xg77-xqhq-crpr
Remediation
- Fix · GHSA-xg77-xqhq-crpr io.jenkins.plugins:code-coverage-api (Maven) Fixed in 1.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2106
- 2026-10-03 Alias added: GHSA-xg77-xqhq-crpr
References
Advisory 3
More Jenkins Code Coverage Api vulnerabilities
- TI-2021-04757 Deserialization of untrusted data in Jenkins Code Coverage API Plugin CVSS 3.1HIGH 8.8
- TI-2020-02049 XML external entity injection in Jenkins Code Coverage API Plugin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2020-2106 · CVE Program
- CVE-2020-2106 · NVD
- FIRST EPSS
- GHSA-xg77-xqhq-crpr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences