Read the docs
TI-2020-02049 Aliases CVE-2020-2172GHSA-cmgm-q8hf-p7jc

XML external entity injection in Jenkins Code Coverage API Plugin

Priority LOW 31CWE-776Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.

Summary

Jenkins Code Coverage API Plugin 1.1.4 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Why it matters now

EPSS 0.01067 64th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:code-coverage-api (Maven): 1.1.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Code Coverage API Pluginup to 1.1.4—No fix listedCNA
—io.jenkins.plugins:code-coverage-api (Maven)before 1.1.51.1.5Patch availableGHSA-cmgm-q8hf-p7jc
  • Jenkins Code Coverage API Plugin VendorJenkins Affected up to 1.1.4 Fixed in — No fix listed CNA
  • io.jenkins.plugins:code-coverage-api (Maven) Vendor— Affected before 1.1.5 Fixed in 1.1.5 Patch available GHSA-cmgm-q8hf-p7jc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:code_coverage_api:*:*:*:*:*:jenkins:*:*up to 1.1.4VulnerableJenkins
  • cpe:2.3:a:jenkins:code_coverage_api:*:*:*:*:*:jenkins:*:* Versions up to 1.1.4 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-cmgm-q8hf-p7jc io.jenkins.plugins:code-coverage-api (Maven) Fixed in 1.1.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-2172
  2. 2026-10-03 Alias added: GHSA-cmgm-q8hf-p7jc

References

  • TI-2021-04757 Deserialization of untrusted data in Jenkins Code Coverage API Plugin CVSS 3.1HIGH 8.8
  • TI-2020-01983 Cross-site scripting in Jenkins Code Coverage API Plugin CVSS 3.1MEDIUM 5.4

Sources