Read the docs
TI-2020-01989 Aliases CVE-2020-2112GHSA-hw26-fw67-qxm9

Cross-site scripting in Jenkins Git Parameter Plugin

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Git Parameter Plugin 0.9.11 and earlier does not escape the parameter name shown on the UI, resulting in a stored cross-site scripting vulnerability exploitable by users with Job/Configure permission.

Why it matters now

EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.tools:git-parameter (Maven): 0.9.12

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Git Parameter Plugin0.9.4 and later; up to 0.9.11—No fix listedCNA
—org.jenkins-ci.tools:git-parameter (Maven)before 0.9.120.9.12Patch availableGHSA-hw26-fw67-qxm9
  • Jenkins Git Parameter Plugin VendorJenkins Affected 0.9.4 and later; up to 0.9.11 Fixed in — No fix listed CNA
  • org.jenkins-ci.tools:git-parameter (Maven) Vendor— Affected before 0.9.12 Fixed in 0.9.12 Patch available GHSA-hw26-fw67-qxm9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:git_parameter:*:*:*:*:*:jenkins:*:*up to 0.9.11VulnerableJenkins
  • cpe:2.3:a:jenkins:git_parameter:*:*:*:*:*:jenkins:*:* Versions up to 0.9.11 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-hw26-fw67-qxm9 org.jenkins-ci.tools:git-parameter (Maven) Fixed in 0.9.12 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Jenkins Git Parameter Plugin unspecified

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2020-01990 Cross-site scripting in Jenkins Git Parameter PluginPriority LOW 26

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-2112
  2. 2026-10-03 Alias added: GHSA-hw26-fw67-qxm9

References

  • TI-2025-33576 Improper input validation in Jenkins Git Parameter Plugin CVSS 3.1HIGH 8.2
  • TI-2022-11606 Cross-site scripting in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 5.4
  • TI-2020-02115 Cross-site scripting in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 5.4
  • TI-2020-01990 Cross-site scripting in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 5.4
  • TI-2026-41223 Missing authorization in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 4.3

Sources