Cross-site scripting in Jenkins Git Parameter Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Git Parameter Plugin 0.9.15 and earlier does not escape the name and description of Git parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.0083 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.tools:git-parameter (Maven): 0.9.16
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Git Parameter Plugin | up to 0.9.15 | — | No fix listed | CNA |
| — | org.jenkins-ci.tools:git-parameter (Maven) | before 0.9.16 | 0.9.16 | Patch available | GHSA-fcr6-6cph-vmcm |
- Jenkins Git Parameter Plugin VendorJenkins Affected up to 0.9.15 Fixed in — No fix listed CNA
- org.jenkins-ci.tools:git-parameter (Maven) Vendor— Affected before 0.9.16 Fixed in 0.9.16 Patch available GHSA-fcr6-6cph-vmcm
Remediation
- Fix · GHSA-fcr6-6cph-vmcm org.jenkins-ci.tools:git-parameter (Maven) Fixed in 0.9.16 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29040
- 2026-10-03 Alias added: GHSA-fcr6-6cph-vmcm
References
More Jenkins Git Parameter vulnerabilities
- TI-2025-33576 Improper input validation in Jenkins Git Parameter Plugin CVSS 3.1HIGH 8.2
- TI-2020-02115 Cross-site scripting in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 5.4
- TI-2020-01990 Cross-site scripting in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 5.4
- TI-2020-01989 Cross-site scripting in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 5.4
- TI-2026-41223 Missing authorization in Jenkins Git Parameter Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-29040 · CVE Program
- CVE-2022-29040 · NVD
- FIRST EPSS
- GHSA-fcr6-6cph-vmcm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences