Read the docs
TI-2020-02039 Aliases CVE-2020-2162GHSA-crg2-6xv3-qg5f

Cross-site scripting in Jenkins

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Jenkins 2.227 and earlier, LTS 2.204.5 and earlier does not set Content-Security-Policy headers for files uploaded as file parameters to a build, resulting in a stored XSS vulnerability.

Why it matters now

EPSS 0.01159 67th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.228

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkinsup to 2.227; up to LTS 2.204.5—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.2282.228Patch availableGHSA-crg2-6xv3-qg5f
—org.jenkins-ci.main:jenkins-core (Maven)2.204.6 to before 2.2282.228Patch availableGHSA-crg2-6xv3-qg5f
  • Jenkins VendorJenkins Affected up to 2.227; up to LTS 2.204.5 Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.228 Fixed in 2.228 Patch available GHSA-crg2-6xv3-qg5f
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.204.6 to before 2.228 Fixed in 2.228 Patch available GHSA-crg2-6xv3-qg5f

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.204.5VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.227VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.204.5 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.227 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-crg2-6xv3-qg5f org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.228 Advisory →
  • Fix · GHSA-crg2-6xv3-qg5f org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.228 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11Fixed—
Red Hat OpenShift Container Platform 4.3Fixed—
Red Hat OpenShift Container Platform 4.4Fixed—
Not affected: 1 product
  • Red Hat OpenShift Container Platform 3.11

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-2162
  2. 2026-10-03 Alias added: GHSA-crg2-6xv3-qg5f

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources