Insufficiently protected credentials in Jenkins Artifactory Plugin
Priority LOW 35CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Artifactory Plugin 3.6.0 and earlier transmits configured passwords in plain text as part of its global Jenkins configuration form, potentially resulting in their exposure.
Why it matters now
EPSS 0.01086 65th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:artifactory (Maven): 3.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Artifactory Plugin | 3.6.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:artifactory (Maven) | before 3.6.1 | 3.6.1 | Patch available | GHSA-xqf6-5grh-6223 |
- Jenkins Artifactory Plugin VendorJenkins Affected 3.6.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:artifactory (Maven) Vendor— Affected before 3.6.1 Fixed in 3.6.1 Patch available GHSA-xqf6-5grh-6223
Remediation
- Fix · GHSA-xqf6-5grh-6223 org.jenkins-ci.plugins:artifactory (Maven) Fixed in 3.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2165
- 2026-10-03 Alias added: GHSA-xqf6-5grh-6223
References
Advisory 2
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2020-2165 · CVE Program
- CVE-2020-2165 · NVD
- FIRST EPSS
- GHSA-xqf6-5grh-6223 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences