Cross-site scripting in Jenkins
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins 2.244 and earlier, LTS 2.235.1 and earlier does not escape the agent name in the build time trend page, resulting in a stored cross-site scripting vulnerability.
Why it matters now
EPSS 0.01023 63rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.235.2, 2.245Red Hat: 4 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins | up to 2.244; up to LTS 2.235.1 | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.235.2 | 2.235.2 | Patch available | GHSA-qgj4-rc8m-44mq |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.236 to before 2.245 | 2.245 | Patch available | GHSA-qgj4-rc8m-44mq |
- Jenkins VendorJenkins Affected up to 2.244; up to LTS 2.235.1 Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.235.2 Fixed in 2.235.2 Patch available GHSA-qgj4-rc8m-44mq
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.236 to before 2.245 Fixed in 2.245 Patch available GHSA-qgj4-rc8m-44mq
Remediation
- Fix · GHSA-qgj4-rc8m-44mq org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.235.2 Advisory →
- Fix · GHSA-qgj4-rc8m-44mq org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.245 Advisory →
Red Hat 4 advisories
- RHSA-2020:3808 Released 2020-09-23 · Red Hat rating ImportantOpenShift Container Platform 4.3.38 jenkins and openshift security update
- Red Hat OpenShift Container Platform 4.3 jenkins-2.235.5.1600415514-1.el7, openshift-4.3.37-202009120213.p0.git.0.dffefe4.el8, openshift-hyperkube-4.3.37-202009120213.p0.git.0.dffefe4.el8
- RHSA-2020:3579 Released 2020-09-01 · Red Hat rating ModerateOpenShift Container Platform 4.4.19 openshift security update
- Red Hat OpenShift Container Platform 4.4 openshift-4.4.0-202008250319.p0.git.0.d653415.el7, openshift-4.4.0-202008250319.p0.git.0.d653415.el8, openshift-hyperkube-4.4.0-202008250319.p0.git.0.d653415.el7 +1
- RHSA-2020:3541 Released 2020-08-27 · Red Hat rating ImportantOpenShift Container Platform 3.11 security update
- Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins-3.11.1597310986-1.el7, jenkins-2.235.2.1597220898-1.el7, openshift-ansible-3.11.272-1.git.0.79ab6e9.el7 +6
Show 1 more Red Hat advisories
- RHSA-2020:3519 Released 2020-08-24 · Red Hat rating ImportantOpenShift Container Platform 4.5.7 jenkins and openshift packages security update
- Red Hat OpenShift Container Platform 4.5 jenkins-2.235.2.1597312414-1.el7, openshift-4.5.0-202008130146.p0.git.0.aaf1d57.el7, openshift-4.5.0-202008130146.p0.git.0.aaf1d57.el8 +2
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2020:3541 |
| Red Hat OpenShift Container Platform 4.3 | Fixed | RHSA-2020:3808 |
| Red Hat OpenShift Container Platform 4.4 | Fixed | RHSA-2020:3579 |
| Red Hat OpenShift Container Platform 4.5 | Fixed | RHSA-2020:3519 |
| Red Hat OpenShift Container Platform 4.6 | Fixed | — |
Not affected: 4 products
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4.3
- Red Hat OpenShift Container Platform 4.4
- Red Hat OpenShift Container Platform 4.5
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2220
- 2026-10-03 Alias added: GHSA-qgj4-rc8m-44mq
- 2026-10-30 Fix available: Red Hat OpenShift Container Platform 4.6 · Red Hat
References
Advisory 3
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2020-2220 · CVE Program
- CVE-2020-2220 · NVD
- FIRST EPSS
- GHSA-qgj4-rc8m-44mq · GitHub Advisory Database · CC BY 4.0
- CVE-2020-2220 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences