Insufficiently protected credentials in Jenkins AppSpider Plugin
Priority LOW 25CWE-522Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins AppSpider Plugin 1.0.12 and earlier stores a password unencrypted in its global configuration file on the Jenkins controller where it can be viewed by users with access to the Jenkins controller file system.
Why it matters now
EPSS 0.00328 26th percentileScored 2026-11-07
Fix Fixed com.rapid7:jenkinsci-appspider-plugin (Maven): 1.0.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins AppSpider Plugin | up to 1.0.12 | — | No fix listed | CNA |
| — | com.rapid7:jenkinsci-appspider-plugin (Maven) | before 1.0.13 | 1.0.13 | Patch available | GHSA-rm7r-xv53-xwc3 |
- Jenkins AppSpider Plugin VendorJenkins Affected up to 1.0.12 Fixed in — No fix listed CNA
- com.rapid7:jenkinsci-appspider-plugin (Maven) Vendor— Affected before 1.0.13 Fixed in 1.0.13 Patch available GHSA-rm7r-xv53-xwc3
Remediation
- Fix · GHSA-rm7r-xv53-xwc3 com.rapid7:jenkinsci-appspider-plugin (Maven) Fixed in 1.0.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2314
- 2026-10-03 Alias added: GHSA-rm7r-xv53-xwc3
References
More Jenkins Appspider vulnerabilities
- TI-2023-16186 Cross-site request forgery in Jenkins AppSpider Plugin CVSS 3.1HIGH 8.8
- TI-2023-16187 Incorrect default permissions in Jenkins AppSpider Plugin CVSS 3.1MEDIUM 4.3
- TI-2024-18733 Missing authorization in Jenkins AppSpider Plugin CVSS 3.1MEDIUM 4.3
- TI-2026-36182 Improper privilege management in Jenkins AppSpider Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2020-2314 · CVE Program
- CVE-2020-2314 · NVD
- FIRST EPSS
- GHSA-rm7r-xv53-xwc3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences