Improper privilege management in Jenkins AppSpider Plugin
Priority LOW 19CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
Jenkins AppSpider Plugin 1.0.17 and earlier does not perform a permission check in a method implementing form validation, allowing attackers with Overall/Read permission to connect to an attacker-specified URL.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0018 7th percentileScored 2026-11-07
Fix Fixed com.rapid7:jenkinsci-appspider-plugin (Maven): 1.0.18
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins AppSpider Plugin | up to 1.0.17 | — | No fix listed | CNA |
| — | com.rapid7:jenkinsci-appspider-plugin (Maven) | before 1.0.18 | 1.0.18 | Patch available | GHSA-9wm7-8qf3-9v98 |
- Jenkins AppSpider Plugin VendorJenkins Affected up to 1.0.17 Fixed in — No fix listed CNA
- com.rapid7:jenkinsci-appspider-plugin (Maven) Vendor— Affected before 1.0.18 Fixed in 1.0.18 Patch available GHSA-9wm7-8qf3-9v98
Remediation
- Fix · GHSA-9wm7-8qf3-9v98 com.rapid7:jenkinsci-appspider-plugin (Maven) Fixed in 1.0.18 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-48923
- 2026-10-03 Alias added: GHSA-9wm7-8qf3-9v98
References
More Jenkins Appspider vulnerabilities
- TI-2023-16186 Cross-site request forgery in Jenkins AppSpider Plugin CVSS 3.1HIGH 8.8
- TI-2020-02191 Insufficiently protected credentials in Jenkins AppSpider Plugin CVSS 3.1MEDIUM 5.5
- TI-2023-16187 Incorrect default permissions in Jenkins AppSpider Plugin CVSS 3.1MEDIUM 4.3
- TI-2024-18733 Missing authorization in Jenkins AppSpider Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-48923 · CVE Program
- CVE-2026-48923 · NVD
- FIRST EPSS
- GHSA-9wm7-8qf3-9v98 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences