Missing authorization in Jenkins Chaos Monkey Plugin
Priority LOW 36CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Denial of service
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862 and CWE-401.
Summary
Jenkins Chaos Monkey Plugin 0.3 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to generate load and to generate memory leaks.
Why it matters now
EPSS 0.01339 71st percentileScored 2026-11-07
Fix Fixed Jenkins Chaos Monkey Plugin (Jenkins project): 0.4.1io.jenkins.plugins:chaos-monkey (Maven): 0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Chaos Monkey Plugin | up to 0.3 | 0.4.1 | Patch available | CNA |
| — | io.jenkins.plugins:chaos-monkey (Maven) | before 0.4 | 0.4 | Patch available | GHSA-mr75-899x-qcxq |
- Jenkins Chaos Monkey Plugin VendorJenkins Affected up to 0.3 Fixed in 0.4.1 Patch available CNA
- io.jenkins.plugins:chaos-monkey (Maven) Vendor— Affected before 0.4 Fixed in 0.4 Patch available GHSA-mr75-899x-qcxq
Remediation
- Fix · CNA Jenkins Chaos Monkey Plugin (Jenkins project) Fixed in 0.4.1
- Fix · GHSA-mr75-899x-qcxq io.jenkins.plugins:chaos-monkey (Maven) Fixed in 0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2322
- 2026-10-03 Alias added: GHSA-mr75-899x-qcxq
References
Advisory 2
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2020-2322 · CVE Program
- CVE-2020-2322 · NVD
- FIRST EPSS
- GHSA-mr75-899x-qcxq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences