Missing authorization in Jenkins Chaos Monkey Plugin
Priority LOW 26CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Jenkins Chaos Monkey Plugin 0.4 and earlier does not perform permission checks in an HTTP endpoint, allowing attackers with Overall/Read permission to access the Chaos Monkey page and to see the history of actions.
Why it matters now
EPSS 0.00834 57th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:chaos-monkey (Maven): 0.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Chaos Monkey Plugin | up to 0.4 | — | No fix listed | CNA |
| — | io.jenkins.plugins:chaos-monkey (Maven) | before 0.4.1 | 0.4.1 | Patch available | GHSA-hx53-635r-vmv8 |
- Jenkins Chaos Monkey Plugin VendorJenkins Affected up to 0.4 Fixed in — No fix listed CNA
- io.jenkins.plugins:chaos-monkey (Maven) Vendor— Affected before 0.4.1 Fixed in 0.4.1 Patch available GHSA-hx53-635r-vmv8
Remediation
- Fix · GHSA-hx53-635r-vmv8 io.jenkins.plugins:chaos-monkey (Maven) Fixed in 0.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2323
- 2026-10-03 Alias added: GHSA-hx53-635r-vmv8
References
Advisory 2
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2020-2323 · CVE Program
- CVE-2020-2323 · NVD
- FIRST EPSS
- GHSA-hx53-635r-vmv8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences