Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Priority LOW 36CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-611 and the CVSS impact.
Summary
Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
Why it matters now
EPSS 0.01358 71st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:cvs (Maven): 2.17
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins CVS Plugin | up to 2.16 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:cvs (Maven) | before 2.17 | 2.17 | Patch available | GHSA-g9hg-x9c9-7xgr |
- Jenkins CVS Plugin VendorJenkins Affected up to 2.16 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:cvs (Maven) Vendor— Affected before 2.17 Fixed in 2.17 Patch available GHSA-g9hg-x9c9-7xgr
Remediation
- Fix · GHSA-g9hg-x9c9-7xgr org.jenkins-ci.plugins:cvs (Maven) Fixed in 2.17 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-2324
- 2026-10-03 Alias added: GHSA-g9hg-x9c9-7xgr
References
Advisory 3
More Jenkins Cvs vulnerabilities
- TI-2022-11603 Cross-site scripting in Jenkins CVS Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2020-2324 · CVE Program
- CVE-2020-2324 · NVD
- FIRST EPSS
- GHSA-g9hg-x9c9-7xgr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences