Cross-site scripting in Jenkins CVS Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins CVS Plugin 2.19 and earlier does not escape the name and description of CVS Symbolic Name parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.00689 53rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:cvs (Maven): 2.19.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins CVS Plugin | up to 2.19 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:cvs (Maven) | before 2.19.1 | 2.19.1 | Patch available | GHSA-ghq2-m3pq-qf3p |
- Jenkins CVS Plugin VendorJenkins Affected up to 2.19 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:cvs (Maven) Vendor— Affected before 2.19.1 Fixed in 2.19.1 Patch available GHSA-ghq2-m3pq-qf3p
Remediation
- Fix · GHSA-ghq2-m3pq-qf3p org.jenkins-ci.plugins:cvs (Maven) Fixed in 2.19.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29037
- 2026-10-03 Alias added: GHSA-ghq2-m3pq-qf3p
References
More Jenkins Cvs vulnerabilities
- TI-2020-02201 Jenkins CVS Plugin 2.16 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. CVSS 3.1HIGH 7.5
Sources
- CVE-2022-29037 · CVE Program
- CVE-2022-29037 · NVD
- FIRST EPSS
- GHSA-ghq2-m3pq-qf3p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences