XSS in Dijit Editor's LinkDialog plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dojo | dijit | before 1.11.11; 1.12.0 to before 1.12.9; 1.13.0 to before 1.13.8; 1.14.0 to before 1.14.7; 1.15.0 to before 1.15.4; 1.16.0 to before 1.16.3 | 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3 | Patch available | CNA |
| — | dijit (npm) | before 1.11.11 | 1.11.11 | Patch available | GHSA-cxjc-r2fp-7mq6 |
| — | dijit (npm) | 1.12.0 to before 1.12.9 | 1.12.9 | Patch available | GHSA-cxjc-r2fp-7mq6 |
| — | dijit (npm) | 1.13.0 to before 1.13.8 | 1.13.8 | Patch available | GHSA-cxjc-r2fp-7mq6 |
| — | dijit (npm) | 1.14.0 to before 1.14.7 | 1.14.7 | Patch available | GHSA-cxjc-r2fp-7mq6 |
| — | dijit (npm) | 1.15.0 to before 1.15.4 | 1.15.4 | Patch available | GHSA-cxjc-r2fp-7mq6 |
| — | dijit (npm) | 1.16.0 to before 1.16.3 | 1.16.3 | Patch available | GHSA-cxjc-r2fp-7mq6 |
- dijit Vendordojo Affected before 1.11.11; 1.12.0 to before 1.12.9; 1.13.0 to before 1.13.8; 1.14.0 to before 1.14.7; 1.15.0 to before 1.15.4; 1.16.0 to before 1.16.3 Fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3 Patch available CNA
- dijit (npm) Vendor— Affected before 1.11.11 Fixed in 1.11.11 Patch available GHSA-cxjc-r2fp-7mq6
- dijit (npm) Vendor— Affected 1.12.0 to before 1.12.9 Fixed in 1.12.9 Patch available GHSA-cxjc-r2fp-7mq6
- dijit (npm) Vendor— Affected 1.13.0 to before 1.13.8 Fixed in 1.13.8 Patch available GHSA-cxjc-r2fp-7mq6
- dijit (npm) Vendor— Affected 1.14.0 to before 1.14.7 Fixed in 1.14.7 Patch available GHSA-cxjc-r2fp-7mq6
- dijit (npm) Vendor— Affected 1.15.0 to before 1.15.4 Fixed in 1.15.4 Patch available GHSA-cxjc-r2fp-7mq6
- dijit (npm) Vendor— Affected 1.16.0 to before 1.16.3 Fixed in 1.16.3 Patch available GHSA-cxjc-r2fp-7mq6
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:* | before 1.11.11; 1.12.0 to before 1.12.9; 1.13.0 to before 1.13.8; 1.14.0 to before 1.14.7; 1.15.0 to before 1.15.4; 1.16.0 to before 1.16.3 | Vulnerable | fast-uri |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:openjsf:dijit:*:*:*:*:*:*:*:* Versions before 1.11.11; 1.12.0 to before 1.12.9; 1.13.0 to before 1.13.8; 1.14.0 to before 1.14.7; 1.15.0 to before 1.15.4; 1.16.0 to before 1.16.3 Vulnerable ·fast-uri
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:vmware_vsphere:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:-:*:*:*:*:windows:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · CNA dijit (Dojo) Fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3
- Fix · GHSA-cxjc-r2fp-7mq6 dijit (npm) Fixed in 1.11.11 Advisory →
- Fix · GHSA-cxjc-r2fp-7mq6 dijit (npm) Fixed in 1.12.9 Advisory →
- Fix · GHSA-cxjc-r2fp-7mq6 dijit (npm) Fixed in 1.13.8 Advisory →
- Fix · GHSA-cxjc-r2fp-7mq6 dijit (npm) Fixed in 1.14.7 Advisory →
- Fix · GHSA-cxjc-r2fp-7mq6 dijit (npm) Fixed in 1.15.4 Advisory →
- Fix · GHSA-cxjc-r2fp-7mq6 dijit (npm) Fixed in 1.16.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2020-4051
- 2026-10-03 Alias added: GHSA-cxjc-r2fp-7mq6
References
Patch 2
Advisory 4
More dojo vulnerabilities
- TI-2020-04314 Prototype pollution in dojo CVSS 3.1HIGH 7.7
- TI-2020-04315 Prototype Pollution in Dojox CVSS 3.1HIGH 8.6
- TI-2023-17567 WordPress WP Affiliate Links Plugin <= 0.1.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
Sources
- CVE-2020-4051 · CVE Program
- CVE-2020-4051 · NVD
- FIRST EPSS
- GHSA-cxjc-r2fp-7mq6 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-4051 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences