Read the docs
TI-2020-04315 Aliases CVE-2020-5259GHSA-3hw5-q855-g6cw

Prototype Pollution in Dojox

Priority MEDIUM 41CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

In affected versions of dojox (NPM package), the jqMix method is vulnerable to Prototype Pollution. Prototype Pollution refers to the ability to inject properties into existing JavaScript language construct prototypes, such as objects. An attacker manipulates these attributes to overwrite, or pollute, a JavaScript application object prototype of the base object by injecting other values. This has been patched in versions 1.11.10, 1.12.8, 1.13.7, 1.14.6, 1.15.3 and 1.16.2

Why it matters now

EPSS 0.02018 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed dojox (dojo): 1.11.10, 1.12.8, 1.13.7 +3dojox (npm): 1.11.10, 1.12.8, 1.13.7 +3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
dojodojoxbefore 1.11.10; 1.12.0 to before 1.12.8; 1.13.0 to before 1.13.7; 1.14.0 to before 1.14.6; 1.15.0 to before 1.15.3; 1.16.0 to before 1.16.21.11.10, 1.12.8, 1.13.7, 1.14.6, 1.15.3, 1.16.2Patch availableCNA
—dojox (npm)before 1.11.101.11.10Patch availableGHSA-3hw5-q855-g6cw
—dojox (npm)1.12.0 to before 1.12.81.12.8Patch availableGHSA-3hw5-q855-g6cw
—dojox (npm)1.13.0 to before 1.13.71.13.7Patch availableGHSA-3hw5-q855-g6cw
—dojox (npm)1.14.0 to before 1.14.61.14.6Patch availableGHSA-3hw5-q855-g6cw
—dojox (npm)1.15.0 to before 1.15.31.15.3Patch availableGHSA-3hw5-q855-g6cw
—dojox (npm)1.16.0 to before 1.16.21.16.2Patch availableGHSA-3hw5-q855-g6cw
  • dojox Vendordojo Affected before 1.11.10; 1.12.0 to before 1.12.8; 1.13.0 to before 1.13.7; 1.14.0 to before 1.14.6; 1.15.0 to before 1.15.3; 1.16.0 to before 1.16.2 Fixed in 1.11.10, 1.12.8, 1.13.7, 1.14.6, 1.15.3, 1.16.2 Patch available CNA
  • dojox (npm) Vendor— Affected before 1.11.10 Fixed in 1.11.10 Patch available GHSA-3hw5-q855-g6cw
  • dojox (npm) Vendor— Affected 1.12.0 to before 1.12.8 Fixed in 1.12.8 Patch available GHSA-3hw5-q855-g6cw
  • dojox (npm) Vendor— Affected 1.13.0 to before 1.13.7 Fixed in 1.13.7 Patch available GHSA-3hw5-q855-g6cw
  • dojox (npm) Vendor— Affected 1.14.0 to before 1.14.6 Fixed in 1.14.6 Patch available GHSA-3hw5-q855-g6cw
  • dojox (npm) Vendor— Affected 1.15.0 to before 1.15.3 Fixed in 1.15.3 Patch available GHSA-3hw5-q855-g6cw
  • dojox (npm) Vendor— Affected 1.16.0 to before 1.16.2 Fixed in 1.16.2 Patch available GHSA-3hw5-q855-g6cw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:linuxfoundation:dojox:*:*:*:*:*:node.js:*:*before 1.11.10; 1.12.0 to before 1.12.8; 1.13.0 to before 1.13.7; 1.14.0 to before 1.14.6; 1.15.0 to before 1.15.3; 1.16.0 to before 1.16.2Vulnerablebackstage
  • cpe:2.3:a:linuxfoundation:dojox:*:*:*:*:*:node.js:*:* Versions before 1.11.10; 1.12.0 to before 1.12.8; 1.13.0 to before 1.13.7; 1.14.0 to before 1.14.6; 1.15.0 to before 1.15.3; 1.16.0 to before 1.16.2 Vulnerable ·backstage

Remediation

  • Fix · CNA dojox (dojo) Fixed in 1.11.10, 1.12.8, 1.13.7, 1.14.6, 1.15.3, 1.16.2
  • Fix · GHSA-3hw5-q855-g6cw dojox (npm) Fixed in 1.11.10 Advisory →
  • Fix · GHSA-3hw5-q855-g6cw dojox (npm) Fixed in 1.12.8 Advisory →
  • Fix · GHSA-3hw5-q855-g6cw dojox (npm) Fixed in 1.13.7 Advisory →
  • Fix · GHSA-3hw5-q855-g6cw dojox (npm) Fixed in 1.14.6 Advisory →
  • Fix · GHSA-3hw5-q855-g6cw dojox (npm) Fixed in 1.15.3 Advisory →
  • Fix · GHSA-3hw5-q855-g6cw dojox (npm) Fixed in 1.16.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-5259
  2. 2026-10-03 Alias added: GHSA-3hw5-q855-g6cw

References

  • TI-2020-04314 Prototype pollution in dojo CVSS 3.1HIGH 7.7
  • TI-2023-17567 WordPress WP Affiliate Links Plugin <= 0.1.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2020-03540 XSS in Dijit Editor's LinkDialog plugin CVSS 3.1MEDIUM 5.4

Sources