XSS/Script injection vulnerability in matestack
Priority LOW 35CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
matestack-ui-core (RubyGem) before 0.7.4 is vulnerable to XSS/Script injection. This vulnerability is patched in version 0.7.4.
Why it matters now
EPSS 0.00627 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed matestack-ui-core (matestack): 0.7.4matestack-ui-core (RubyGems): 0.7.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| matestack | matestack-ui-core | before 0.7.4 | 0.7.4 | Patch available | CNA |
| — | matestack-ui-core (RubyGems) | before 0.7.4 | 0.7.4 | Patch available | GHSA-3jqw-vv45-mjhh |
- matestack-ui-core Vendormatestack Affected before 0.7.4 Fixed in 0.7.4 Patch available CNA
- matestack-ui-core (RubyGems) Vendor— Affected before 0.7.4 Fixed in 0.7.4 Patch available GHSA-3jqw-vv45-mjhh
Remediation
- Fix · CNA matestack-ui-core (matestack) Fixed in 0.7.4
- Fix · GHSA-3jqw-vv45-mjhh matestack-ui-core (RubyGems) Fixed in 0.7.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5241
- 2026-10-03 Alias added: GHSA-3jqw-vv45-mjhh
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
Other 4
- https://github.com/matestack/matestack-ui-core/commit/5c61571739e860db9ca578fe09ab4733878cb0fc
- https://github.com/matestack/matestack-ui-core/commit/e96915cf20c4fa0571df7fa21e9b09a69be19107
- https://github.com/matestack/matestack-ui-core
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/matestack-ui-core/CVE-2020-5241.yml
Sources
- CVE-2020-5241 · CVE Program
- CVE-2020-5241 · NVD
- FIRST EPSS
- GHSA-3jqw-vv45-mjhh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences