Signature Wrapping Vulnerability with spring-security-saml2-service-provider
Priority MEDIUM 40CWE-347Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
Spring Security versions 5.2.x prior to 5.2.4 and 5.3.x prior to 5.3.2 contain a signature wrapping vulnerability during SAML response validation. When using the spring-security-saml2-service-provider component, a malicious user can carefully modify an otherwise valid SAML response and append an arbitrary assertion that Spring Security will accept as valid.
Why it matters now
EPSS 0.01199 68th percentileScored 2026-11-07
Fix Fixed Spring Security (Spring by VMware): 5.2.4, 5.3.2org.springframework.security:spring-security-core (Maven): 5.2.4, 5.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Spring Security | 5.2 to before 5.2.4; 5.3 to before 5.3.2 | 5.2.4, 5.3.2 | Patch available | CNA |
| — | org.springframework.security:spring-security-core (Maven) | 5.2.0 to before 5.2.4 | 5.2.4 | Patch available | GHSA-48rw-j489-928m |
| — | org.springframework.security:spring-security-core (Maven) | 5.3.0 to before 5.3.2 | 5.3.2 | Patch available | GHSA-48rw-j489-928m |
- Spring Security VendorVMware Affected 5.2 to before 5.2.4; 5.3 to before 5.3.2 Fixed in 5.2.4, 5.3.2 Patch available CNA
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 5.2.0 to before 5.2.4 Fixed in 5.2.4 Patch available GHSA-48rw-j489-928m
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 5.3.0 to before 5.3.2 Fixed in 5.3.2 Patch available GHSA-48rw-j489-928m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:spring_security:*:*:*:*:*:*:*:* | 5.2.0 to before 5.2.4; 5.3.0 to before 5.3.2 | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:pivotal_software:spring_security:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.2.4; 5.3.0 to before 5.3.2 Vulnerable ·Spring by Pivotal
Remediation
- Fix · CNA Spring Security (Spring by VMware) Fixed in 5.2.4, 5.3.2
- Fix · GHSA-48rw-j489-928m org.springframework.security:spring-security-core (Maven) Fixed in 5.2.4 Advisory →
- Fix · GHSA-48rw-j489-928m org.springframework.security:spring-security-core (Maven) Fixed in 5.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5407
- 2026-10-03 Alias added: GHSA-48rw-j489-928m
References
Advisory 2
Other 9
- [servicemix-issues] 20200514 [jira] [Created] (SM-4384) Create OSGi bundles for spring-security 5.3.2.RELEASE + 5.1.10.RELEASE
- [geode-dev] 20200521 Re: Proposal to backport GEODE-8167
- [geode-dev] 20200521 Proposal to backport GEODE-8167
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://lists.apache.org/thread.html/r73af928cf64bebf78b7fa4bc56a5253273ec7829f5f5827f64c72fc7@%3Cissues.servicemix.apache.org%3E
- https://lists.apache.org/thread.html/ra19a4e7236877fe12bfb52db07b27ad72d9e7a9f5e27bba7e928e18a@%3Cdev.geode.apache.org%3E
- https://lists.apache.org/thread.html/rd99601fbca514f214f88f9e53fd5be3cfbff05b350c994b4ec2e184c@%3Cdev.geode.apache.org%3E
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-5407 · CVE Program
- CVE-2020-5407 · NVD
- FIRST EPSS
- GHSA-48rw-j489-928m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences