RabbitMQ arbitrary code execution using local binary planting
Priority LOW 30CWE-427Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-427.
Summary
RabbitMQ versions 3.8.x prior to 3.8.7 are prone to a Windows-specific binary planting security vulnerability that allows for arbitrary code execution. An attacker with write privileges to the RabbitMQ installation directory and local access on Windows could carry out a local binary hijacking (planting) attack and execute arbitrary code.
Why it matters now
EPSS 0.00452 39th percentileScored 2026-11-07
Fix Fixed RabbitMQ (VMware Tanzu): 3.7.28, 3.8.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | RabbitMQ | 3.7 to before 3.7.28; 3.8 to before 3.8.7 | 3.7.28, 3.8.7 | Patch available | CNA |
- RabbitMQ VendorVMware Affected 3.7 to before 3.7.28; 3.8 to before 3.8.7 Fixed in 3.7.28, 3.8.7 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* | 3.8.0 to before 3.8.7 | Vulnerable | Broadcom |
| cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:*:*:* | before 3.7.28 | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:* Versions 3.8.0 to before 3.8.7 Vulnerable ·Broadcom
- cpe:2.3:a:pivotal_software:rabbitmq:*:*:*:*:*:*:*:* Versions before 3.7.28 Vulnerable ·Spring by Pivotal
Remediation
- Fix · CNA RabbitMQ (VMware Tanzu) Fixed in 3.7.28, 3.8.7
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5419
- 2026-10-03 Alias added: GHSA-82gq-g626-8g5r
References
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-5419 · CVE Program
- CVE-2020-5419 · NVD
- FIRST EPSS
- GHSA-82gq-g626-8g5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences