In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user…
Priority MEDIUM 61CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page. A malicious user could inject custom SQL in place of their own username when creating queries to this page. An attacker must have a valid MySQL account to access the server.
Why it matters now
EPSS 0.28046 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.9.4, 5.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.0.0 to before 4.9.4 | 4.9.4 | Patch available | GHSA-fgj8-93xx-f6g6 |
| — | phpmyadmin/phpmyadmin (Packagist) | 5.0.0 to before 5.0.1 | 5.0.1 | Patch available | GHSA-fgj8-93xx-f6g6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.0.0 to before 4.9.4 Fixed in 4.9.4 Patch available GHSA-fgj8-93xx-f6g6
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 5.0.0 to before 5.0.1 Fixed in 5.0.1 Patch available GHSA-fgj8-93xx-f6g6
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* | 4.0.0 to before 4.9.4; 5.0.0 to before 5.0.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:o:suse:suse_linux_enterprise_server:12:*:*:*:*:*:*:* | 12 | Vulnerable | SUSE |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.9.4; 5.0.0 to before 5.0.1 Vulnerable ·phpMyAdmin
- cpe:2.3:o:suse:suse_linux_enterprise_server:12:*:*:*:*:*:*:* Versions 12 Vulnerable ·SUSE
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-fgj8-93xx-f6g6 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.9.4 Advisory →
- Fix · GHSA-fgj8-93xx-f6g6 phpmyadmin/phpmyadmin (Packagist) Fixed in 5.0.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5504
- 2026-10-03 Alias added: GHSA-fgj8-93xx-f6g6
- 2026-11-03 Priority changed: HIGH → MEDIUM
References
Advisory 3
Sources
- CVE-2020-5504 · CVE Program
- CVE-2020-5504 · NVD
- FIRST EPSS
- GHSA-fgj8-93xx-f6g6 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-5504 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences