Path traversal in EC-CUBE
Priority LOW 39CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Directory traversal vulnerability in EC-CUBE 3.0.0 to 3.0.18 and 4.0.0 to 4.0.3 allows remote authenticated attackers to delete arbitrary files and/or directories on the server via unspecified vectors.
Why it matters now
EPSS 0.02059 81st percentileScored 2026-11-07
Fix Fixed ec-cube/ec-cube (Packagist): 4.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| EC-CUBE CO.,LTD. | EC-CUBE | 3.0.0 to 3.0.18 and 4.0.0 to 4.0.3 | — | No fix listed | CNA |
| — | ec-cube/ec-cube (Packagist) | 3.0.0 – 3.0.18 | — | No fix listed | GHSA-hx79-x87c-hgm3 |
| — | ec-cube/ec-cube (Packagist) | 4.0.0 to before 4.0.4 | 4.0.4 | Patch available | GHSA-hx79-x87c-hgm3 |
- EC-CUBE VendorEC-CUBE CO.,LTD. Affected 3.0.0 to 3.0.18 and 4.0.0 to 4.0.3 Fixed in — No fix listed CNA
- ec-cube/ec-cube (Packagist) Vendor— Affected 3.0.0 – 3.0.18 Fixed in — No fix listed GHSA-hx79-x87c-hgm3
- ec-cube/ec-cube (Packagist) Vendor— Affected 4.0.0 to before 4.0.4 Fixed in 4.0.4 Patch available GHSA-hx79-x87c-hgm3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ec-cube:ec-cube:*:*:*:*:*:*:*:* | 3.0.0 – 3.0.18; 4.0.0 – 4.0.3 | Vulnerable | EC-CUBE CO.,LTD. |
- cpe:2.3:a:ec-cube:ec-cube:*:*:*:*:*:*:*:* Versions 3.0.0 – 3.0.18; 4.0.0 – 4.0.3 Vulnerable ·EC-CUBE CO.,LTD.
Remediation
- Fix · GHSA-hx79-x87c-hgm3 ec-cube/ec-cube (Packagist) Fixed in 4.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-5590
- 2026-10-03 Alias added: GHSA-hx79-x87c-hgm3
References
More EC-CUBE CO.,LTD. Ec-cube vulnerabilities
- TI-2023-25304 Code injection in EC-CUBE 4 series CVSS 3.1HIGH 7.2
- TI-2021-04004 Improper access control vulnerability in EC-CUBE 4.0.6 (EC-CUBE 4 series) allows a remote… CVSS 3.1HIGH 7.5
- TI-2020-04641 Improper input validation in EC-CUBE CVSS 3.1HIGH 7.5
- TI-2008-04745 SQL injection vulnerability in LOCKON CO.,LTD. CVSS 2.0HIGH 7.5
- TI-2008-04326 SQL injection vulnerability in EC-CUBE Ver2 2.1.2a and earlier, and Ver2 RC 2.3.0-rc1 and… CVSS 2.0HIGH 7.5
- TI-2021-04056 Incorrect authorization in EC-CUBE 2 series CVSS 3.1MEDIUM 6.5
Sources
- CVE-2020-5590 · CVE Program
- CVE-2020-5590 · NVD
- FIRST EPSS
- GHSA-hx79-x87c-hgm3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences