Read the docs

EC-CUBE CO.,LTD.

Records40All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high8CVSS 7.0–8.9

Exploited now

EC-CUBE CO.,LTD. records in CISA KEV

No EC-CUBE CO.,LTD. vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

40 records

TI-2014-00744 CVE-2014-0808 · GHSA-j2hg-w4p4-6rvm

Authorization bypass in EC-CUBE

Priority MEDIUM 52

Authorization bypass through user-controlled key issue exists in EC-CUBE 2.11.0 through 2.12.2 and EC-Orange systems deployed before June 29th, 2015.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.02245 Published 2014-01-22 Fixed in 2.12.2 CWE-566
TI-2020-04559 CVE-2020-5590 · GHSA-hx79-x87c-hgm3

Path traversal in EC-CUBE

Priority LOW 39

Directory traversal vulnerability in EC-CUBE 3.0.0 to 3.0.18 and 4.0.0 to 4.0.3 allows remote authenticated attackers to delete arbitrary files and/or directories on the server via unspecified vectors.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.02059 Published 2020-06-19 Fixed in 4.0.4 CWE-22
TI-2023-25304 CVE-2023-46845 · GHSA-cp9w-gp2m-qfm3

Code injection in EC-CUBE 4 series

Priority LOW 37

EC-CUBE 3 series (3.0.0 to 3.0.18-p6) and 4 series (4.0.0 to 4.0.6-p3, 4.1.0 to 4.1.2-p2, and 4.2.0 to 4.2.2) contain an arbitrary code execution vulnerability due to improper settings of the template engine Twig include…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01582 Published 2023-11-07 No fix listed CWE-94
TI-2020-04641 CVE-2020-5680 · GHSA-6wm9-966m-73jr

Improper input validation in EC-CUBE

Priority LOW 36

Improper input validation vulnerability in EC-CUBE versions from 3.0.5 to 3.0.18 allows a remote attacker to cause a denial-of-service (DoS) condition via unspecified vector.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01384 Published 2020-12-03 No fix listed CWE-20
Priority LOW 34

Input validation issue in EC-CUBE Payment Module (2.12) version 3.5.23 and earlier, EC-CUBE Payment Module (2.11) version 2.3.17 and earlier, GMO-PG Payment Module (PG Multi-Payment Service) (2.12) version 3.5.23 and ear…

CVSS 3.0HIGH 7.2 Network High privileges No interaction EPSS 0.01029 Published 2018-09-07 No fix listed CWE-20
TI-2021-04056 CVE-2021-20841 · GHSA-jc55-crg7-pr35

Incorrect authorization in EC-CUBE 2 series

Priority LOW 32

Improper access control in Management screen of EC-CUBE 2 series 2.11.2 to 2.17.1 allows a remote authenticated attacker to bypass access restriction and to alter System settings via unspecified vectors.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01319 Published 2021-11-24 Fixed in 2.17.2 CWE-863
TI-2021-03943 CVE-2021-20717 · GHSA-c8mx-43cq-993w

Cross-site scripting in EC-CUBE

Priority LOW 32

Cross-site scripting vulnerability in EC-CUBE 4.0.0 to 4.0.5 allows a remote attacker to inject a specially crafted script in the specific input field of the EC web site which is created using EC-CUBE.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.02308 Published 2021-05-10 No fix listed CWE-79
TI-2026-23618 CVE-2026-30777 · GHSA-x865-r8g8-5r6r

Authentication bypass in EC-CUBE 4.1 series

Priority LOW 31

EC-CUBE provided by EC-CUBE CO.,LTD.

CVSS 4.0MEDIUM 6.9 Network High privileges No interaction EPSS 0.00385 Published 2026-03-05 Fixed in 4.1.2-p5, 4.2.3-p2 +1 CWE-288
Priority LOW 30

Cross-site request forgery (CSRF) vulnerability in EC-CUBE 2 series 2.11.0 to 2.17.1 allows a remote attacker to hijack the authentication of Administrator and delete Administrator via a specially crafted web page.

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00551 Published 2021-11-24 Fixed in 2.17.2 CWE-352
TI-2021-03976 CVE-2021-20750 · GHSA-vrpv-26fm-7vf7

Cross-site scripting in EC-CUBE

Priority LOW 30

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administra…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01557 Published 2021-06-28 Fixed in 4.0.6 CWE-79
TI-2018-11588 CVE-2018-16191 · GHSA-fcgg-qgxg-2g2x

Open redirect in LOCKON CO.,LTD. EC-CUBE

Priority LOW 30

Open redirect vulnerability in EC-CUBE (EC-CUBE 3.0.0, EC-CUBE 3.0.1, EC-CUBE 3.0.2, EC-CUBE 3.0.3, EC-CUBE 3.0.4, EC-CUBE 3.0.5, EC-CUBE 3.0.6, EC-CUBE 3.0.7, EC-CUBE 3.0.8, EC-CUBE 3.0.9, EC-CUBE 3.0.10, EC-CUBE 3.0.11…

CVSS 3.0MEDIUM 6.1 Network No auth User interaction EPSS 0.01297 Published 2019-01-09 Fixed in 3.0.17 CWE-601
TI-2021-03977 CVE-2021-20751 · GHSA-r6qq-qc9m-98w2

Cross-site scripting in EC-CUBE

Priority LOW 29

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to p…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01088 Published 2021-06-28 Fixed in 4.0.6 CWE-79
Priority LOW 29

Cross-site scripting vulnerability in EC-CUBE Category contents plugin (for EC-CUBE 3.0 series) versions prior to version 1.0.1 allows a remote attacker to inject an arbitrary script by leading an administrator or a user…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00754 Published 2021-06-22 No fix listed CWE-79
Priority LOW 29

Cross-site scripting vulnerability in EC-CUBE Email newsletters management plugin (for EC-CUBE 3.0 series) versions prior to version 1.0.4 allows a remote attacker to inject an arbitrary script by leading a user to a spe…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00754 Published 2021-06-22 No fix listed CWE-79
Priority LOW 29

Cross-site scripting vulnerability in EC-CUBE Business form output plugin (for EC-CUBE 3.0 series) versions prior to version 1.0.1 allows a remote attacker to inject an arbitrary script via unspecified vector.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00757 Published 2021-06-22 No fix listed CWE-79
Priority LOW 29

Cross-site scripting vulnerability in ETUNA EC-CUBE plugins (Delivery slip number plugin (3.0 series) 1.0.10 and earlier, Delivery slip number csv bulk registration plugin (3.0 series) 1.0.8 and earlier, and Delivery sli…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01121 Published 2021-06-22 No fix listed CWE-79
Priority LOW 29

Cross-site scripting vulnerability in EC-CUBE plugin 'Amazon Pay Plugin 2.12,2.13' version 2.4.2 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01031 Published 2019-09-12 No fix listed CWE-79
Priority LOW 28

Cross-site scripting vulnerability in Contents Management of EC-CUBE 4 series (EC-CUBE 4.0.0 to 4.0.6-p2, EC-CUBE 4.1.0 to 4.1.2-p1, and EC-CUBE 4.2.0), EC-CUBE 3 series (EC-CUBE 3.0.0 to 3.0.18-p5), and EC-CUBE 2 series…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00692 Published 2023-03-05 No fix listed CWE-79
TI-2022-18368 CVE-2022-38975 · GHSA-pggw-rqfm-72rh

Cross-site scripting in EC-CUBE 4 series

Priority LOW 28

DOM-based cross-site scripting vulnerability in EC-CUBE 4 series (EC-CUBE 4.0.0 to 4.1.2) allows a remote attacker to inject an arbitrary script by having an administrative user of the product to visit a specially crafte…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00664 Published 2022-09-27 No fix listed CWE-79
Load more
Open these records in search →